Weird iMessage issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
The Technology Section A place to discuss technology & gadgets.

 
Thread Tools
(Post Link) post #1 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

Weird iMessage issue

Since I changed to iPhone 6 (and iOS8 - not sure which change is to blame) I have a problem sending and receiving texts from my wife.

My wife also has an iPhone - and we're both on the same Apple ID. If we're both in wifi range, there's no problem. iMessage works perfectly. But it will not send as an SMS if we're not.

If I turn off iMessage and try to send a text from either phone to the other, it says "iMessage must be enabled to send this message".

Messages to other people with iPhones seem to work normally - it's only between ours.

And a slightly weird side issue. While having them side by side now playing to work out which is the problem, I have tried sending messages with one, the other, or both wifi turned off. Messages have worked - but are going through as iMessages. Eh?

Seen an offensive/spam post? Report it! Click the or button next to the post.
AO Rules - AO Gallery - AO Classified adverts - AO Club - AO Traders

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so." - Douglas Adams


"You know, sometimes the world seems like a pretty mean place."
"That's why animals are so soft and huggy."
- Calvin and Hobbes

To err is human, to moderate ursine.
bazza is offline  
Sponsored Links
Advertisement
 
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,815
Why are you both on the same Apple ID?

I would suggest one of you getting your own ID. You can now share apps with that family share thing anyway so no worries there. Go from there, see if it resolves it.
Pud237 is offline  
(Post Link) post #3 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

Always worked before!

Can't remember why we set it up that way in the first place, it was years ago. Probably to both have access to our music rather than apps (I seem to remember being pleasantly surprised that we only had to buy aps once for both of us.)

Changing one of our apple IDs would seem to be a major faff. I'd rather see if there's an easier solution first.
bazza is offline  
Status: T-5 Days to Unicorn Paradise
AO Platinum Member
 
TheGrimJeeper's Avatar
 
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 38,319
Why not just send a simple SMS...?
TheGrimJeeper is offline  
Status: New badges added :)
AO Member
 
AndyB2801's Avatar
 
Join Date: Jul 2014
Location: United Kingdom
County: Cheshire
Posts: 711

Member car:

Brera 2.2 JTS

Just as a double check, go to settings>messages and then make sure that the "send as SMS" option is enabled.

For the side issue the iMessages could be being sent using your data hence why they worked without wifi on.
AndyB2801 is offline  
(Post Link) post #6 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

You're spot on about the side issue. Hadn't thought it through!

OK, just been on a VERY long chat with Apple support. She was really helpful, and quite fun actually too - so points to Apple for that.

It's sort of fixed...

We logged both phones off their apple ID and back on.

Text messages are now working fine. Except iMessages, when we're on wifi, are now a bit flaky. They were working fine before! Suspect though it's either because iMessage was still resetting itself on Mrs Bazza's phone, or signal here is a little weak. Will try it again once we're home and I know signal won't be to blame. They're going to call me back tomorrow to see if problem continues.
bazza is offline  
(Post Link) post #7 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

Nev - I couldn't send an SMS. That was exactly the problem. If the iMessage failed, then it was refusing to send as an SMS despite having that in the settings. If I turned iMessage off altogether, it told me message couldn't be sent without it.

Now we've got that fixed, we can just send as SMS - even if the new iMessage issue doesn't resolve. I'd rather know everything is working fine than settle for a workaround though.

Oh, and confirmed that being on the sample Apple ID will not be to blame for any of this.
bazza is offline  
(Post Link) post #8 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

Once we've got the problem licked though, I might turn iMessages off anyway. We both come a lot closer to using our data each month than we do to using our text message allowance.
bazza is offline  
Status: New job, location new car :-)
AO Silver Member
 
AmicusPro's Avatar
 
Join Date: Nov 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 3,490

Member car:

159 SW TBi

Do both phones have iMessage enabled with the e-mail address or is the new one just the phone number?
AmicusPro is offline  
Status: T-5 Days to Unicorn Paradise
AO Platinum Member
 
TheGrimJeeper's Avatar
 
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 38,319
Text message "allowance"? How quaint!

I don't think there's anyone who doesn't have unlimited text/call
in France any more.

sms are an overlooked old technology these days.
They can be sent even with a relatively weak signal.

Last edited by TheGrimJeeper; 16-10-14 at 16:12. Reason: Weeeeeak!
TheGrimJeeper is offline  
Status: New Seat Ateca 1.0 SE in my garage
AO Silver Member
 
Alfamack's Avatar
 
Join Date: Apr 2008
Location: United Kingdom
County: Cheshire
Posts: 5,102

Member car:

Seat Ateca SE

Quote:
Originally Posted by Tata4Now View Post
Text message "allowance"? How quaint!

I don't think there's anyone who doesn't have unlimited text/call
in France any more.

sms are an overlooked old technology these days.
They can be sent even with a relatively week signal.
A signal can take a week! Bit like posting a letter.
Alfamack is offline  
(Post Link) post #12 of 16 Old 16-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

Quote:
Originally Posted by AmicusPro View Post
Do both phones have iMessage enabled with the e-mail address or is the new one just the phone number?
Not the new one - the old one (my wife's) doesn't have an email address associated with it.

I've never quite understood what the email address association with an iMessage does. Do you think that adding her email address to her iMessage set up might help?
bazza is offline  
Status: New badges added :)
AO Member
 
AndyB2801's Avatar
 
Join Date: Jul 2014
Location: United Kingdom
County: Cheshire
Posts: 711

Member car:

Brera 2.2 JTS

Quote:
Originally Posted by bazza View Post
Not the new one - the old one (my wife's) doesn't have an email address associated with it.

I've never quite understood what the email address association with an iMessage does. Do you think that adding her email address to her iMessage set up might help?
An issue you might get with this one, is one I had if you have another device like an iPad whereby you will receive messages twice, once on the phone and once on the iPad. I can't see how adding an e-mail to her iMessage would help to be honest but you never know.
AndyB2801 is offline  
Status: New job, location new car :-)
AO Silver Member
 
AmicusPro's Avatar
 
Join Date: Nov 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 3,490

Member car:

159 SW TBi

Quote:
Originally Posted by AndyB2801 View Post
An issue you might get with this one, is one I had if you have another device like an iPad whereby you will receive messages twice, once on the phone and once on the iPad. I can't see how adding an e-mail to her iMessage would help to be honest but you never know.
Just an exploratory question so to speak... Like to get all the facts if I'm troubleshooting (especially with phones I don't own). Usually able to find a solution if one exists... Of courses there's always those odd annoying times.
AmicusPro is offline  
Status: T-5 Days to Unicorn Paradise
AO Platinum Member
 
TheGrimJeeper's Avatar
 
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 38,319
I thoroughly recommend LINE from Japan as a good
all-round multi-platform comms app.


TheGrimJeeper is offline  
(Post Link) post #16 of 16 Old 18-10-14 Thread Starter
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,520

Member car:

AMG C63 estate

All sorted now. The text message refusal was sorted as soon as we logged both phones out of apple ID and back in. The iMessages started working fine again a short while later, so I think the log in process just took a short while.

The support person (on webchat) was both extremely helpful and amusingly friendly too, so good marks to Apple for that.
bazza is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > The Technology Section

Tags
imessage , issue , weird

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome