62 Mito and I - Alfa Romeo Forum
You are currently unregistered, register for more features.    
South Scotland All events and potential meets in South Scotland

 
Thread Tools
(Post Link) post #1 of 2 Old 29-09-18 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2018
County: -
Posts: 3
Talking 62 Mito and I

Hi Guys and Gals,

I am new to this forum so apologies in advance if this isn't the correct protocol for posting.

I currently own an Alfa Mito in Black which is a 62 plate. It is my pride and joy and I absolutely love it, however, I am starting to obtain a few issues.

1st one is my iPhone 8 and the Blue&Me don't get on, at all. I plug it into the USB port and it doesn't recognise it so, therefore, can't play any music ...any ideas?

2nd problem is my door handle on the passenger side, works fine and is still there, however, the little clip/cover that gives the handle a nice finish has fallen off and now it looks horrendous. (See image for accurate representation of what the hell I am on about lol) Any ideas where to get this from without having to replace the whole handle?

lastly and final issue is an upcoming MOT...my exhaust is currently sounding like it has a hole as its really loud and I am forcing myself to believe its the Twinair engine. Anyone got any suggestions of where the best place to take it to get it looked at and get the MOT done for the Mito?

I understand this is quite the list, please bear with me.

TIA xx

Attached Images
File Type: jpg IMG_2623 copy.JPG (123.0 KB, 2 views)
Kaniiz Náziim is offline  
Sponsored Links
Advertisement
 
Status: I used to be Red now I'm Blue
Club Member
Membro Medio
 
PapaSmurf's Avatar
 
Club Member Number: 1451
Join Date: Feb 2011
Location: Perth & Kinross, UK
County: Perth and Kinross
Posts: 4,507
Garage

Member car:

Stelvio Milano

Hi, Welcome to the forum.

Quote:
Originally Posted by Kaniiz Náziim View Post
Hi Guys and Gals,

1st one is my iPhone 8 and the Blue&Me don't get on, at all. I plug it into the USB port and it doesn't recognise it so, therefore, can't play any music ...any ideas?

2nd problem is my door handle on the passenger side, works fine and is still there, however, the little clip/cover that gives the handle a nice finish has fallen off and now it looks horrendous. (See image for accurate representation of what the hell I am on about lol) Any ideas where to get this from without having to replace the whole handle?


You might be better asking these questions in the Mito section https://www.alfaowner.com/Forum/alfa-mito/ They will be best placed to answer your question.

For the MOT, perhaps if you told us where you live we can give you some more help
PapaSmurf is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Scotland > South Scotland

Tags
mito

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome