2.2 check engine light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Republic of Ireland All events and potential meets in Ireland

Reply
 
Thread Tools
(Post Link) post #1 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

2.2 check engine light

Hi Guys,

I know that there are many possibilities for the check engine light so here's my question.

Could you please advise where to go to check whats wrong with the engine? Any decent service?

Thanks,

Cezary
Cezary is offline  
Sponsored Links
Advertisement
 
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
You'll need to get your car to someone with a diagnostic reader.. as you say it could be one of a.dozen reasons..
Ti Autos is highly recommended here....

Do you notice any power/performance loss??
Cathal_H is offline  
(Post Link) post #3 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Bought her with light on so don't really know is there any power loss. I asked a guy in a local garage to reset the error, couldn't read the error code tho.
She's pulling nicely and it seems like everything is ok.
Cezary is offline  
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Ah ok.... Well Congrats on your recent purchase! I wish you well with her...

On the diag light just wondering are you getting under 22 mpg by any chance?
Cathal_H is offline  
(Post Link) post #5 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Thanks Everything is grand except this.

I'm getting now around 19mpg. I'm driving a lot in heavy traffic to and from work.
Cezary is offline  
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Ok low mpg may indicate overfueling/rich running... Due to bad sensor or other device. Obviously hard to tell online here.. one of the other owners Will be on later any may be able to recommend a good garage in your area (im in Cork)..
Cathal_H is offline  
(Post Link) post #7 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

That would be great.

Traveling to Cork would be a bit inconvenient

Guy in the local garage told me that it may be one of the sensors in the cat.
Cezary is offline  
Status: Smells of Eue De Autoglym
AO Gold Member
 
GTV Gav's Avatar
 
Join Date: Jul 2008
Location: Ireland
County: Kildare
Posts: 6,738

Member car:

'96 GTV TS

I'd say just bring it to Gerry in TI Auto's, 1 Cowper Street, Stoneybatter, he'll tell you exactly what is wrong
GTV Gav is offline  
Status: Wondering why people buy so many Audis
AO Silver Member
 
Quadrofoglio's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: West Yorkshire
Posts: 1,225
Bear in mind the stretchy chain issue which affects 2.2s
Quadrofoglio is offline  
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Quote:
Originally Posted by Quadrofoglio View Post
Bear in mind the stretchy chain issue which affects 2.2s
I was trying the dance around this issue and not.scare the new owner!!
Cathal_H is offline  
(Post Link) post #11 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

I'm afraid of the stretched chain. But would that cause higher fuel consumption tho?

Got her really cheap and was prepared for some expenses.

How much would it cost to replace the chain? Any contact for TI Auto's?
Cezary is offline  
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
I had the chain issue after 20k miles... the car was down on power and had low mpg.. the code in memory was. P0016... Its worth a code read ay the least anyway..


It cost me €1000 at the time at a main dealer.. I'm sure an independent would be cheaper... But don't worry yet.... It may well be something small.. fingers crossed!!!
Cathal_H is offline  
(Post Link) post #13 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Yeah, fingers crossed. Will give a call TI Auto's tomorrow.

Too bad I have NCT booked for Thursday Would she pass test with this light on?
Cezary is offline  
Lacken156
Status: - Update
Guest
 
Posts: n/a
been petrol most likely it will, if it does fail its only a visual re-test which is free
 
(Post Link) post #15 of 38 Old 11-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Thanks for all info guys. Much appreciated!

Will go to TI's and see what happens
Cezary is offline  
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Best of luck and let us know how you get on too.....


By the way, don't forget to post pictures of your car too when you have a chance


EDIT : https://www.alfaowner.com/Forum/alfa-...ain-p0016.html

Last edited by Cathal_H; 12-03-12 at 12:12.
Cathal_H is offline  
(Post Link) post #17 of 38 Old 12-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Cathal_H thanks for the link very helpful!!!

I'm going to TI tomorrow so will know whats wrong.
Cezary is offline  
(Post Link) post #18 of 38 Old 15-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Madness

Hi guys,

Went to TI and its not timing chain

One of the variators is failing. Went for nct with check engine light off and she failed on emissions
Cezary is offline  
Lacken156
Status: - Update
Guest
 
Posts: n/a
as you know there are two variators, if replacing one you might as well replace the 2. if the variator is bad that maybe the reason why the emission's were bad. What aspect of the emissions failed? can you put up the report?
 
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Ah crap! well from memory the cam sensors are not massively expensive.. do a.search on the 159 tech forum...

On the bright side when you get it sorted your mpg and power will improve.. you'll love.that engine a lot more..
Cathal_H is offline  
(Post Link) post #21 of 38 Old 15-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Ill replace both. Will go to garage to get estimate tomorrow. Hopefully this will sort the emissions.

Limits are between 0.97 and 1.03. Mine was 1.11
Cezary is offline  
Lacken156
Status: - Update
Guest
 
Posts: n/a
Lambda of 1.11 means that its 'LEAN' & that there is more air been measured than there should be. Most likely you have a hole in the exhaust system. Can you hear a blow in the exhaust any where?

As the NCT probe is only reading from within the back box it does not mean that the actual LAMBDA/s are faulty.
 
Lacken156
Status: - Update
Guest
 
Posts: n/a
Double post.
 
Status: Una nuova auto e necessaria
AO Silver Member
 
Cathal_H's Avatar
 
Join Date: Jun 2008
Location: Ireland
County: Cork
Posts: 2,417
Oh... Lean.. your mpg won't improve so!

Any idea what Pxxxx codes were read from your car??
Cathal_H is offline  
(Post Link) post #25 of 38 Old 15-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2012
Location: Ireland
County: Dublin
Posts: 36

Member car:

159 2.2

Exhaust is really quiet. Too quiet Would love to have double exhaust

Hopefully none of the lambda sonds is faulty.

I had P0013 and P0014 error codes.

Mpg is not that bad cant really complain. Big engine a lot time in heavy traffic.
Cezary is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Ireland > Republic of Ireland

Tags
check , engine , light

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 3 Days Ago 13:36
JTD/JTDM MCSF & other problems FIX losa Alfa 147, 156 & GT 154 26-09-16 20:05
Check engine orange warning light wellerman Alfa 147, 156 & GT 2 30-01-11 09:56
Check Engine Light - How to get rid of it??? Foggy124 Alfa 159, Brera & 946 Spider 3 25-12-09 08:41
Alfa Romeo GT engine check light phantom Alfa 147, 156 & GT 2 07-05-09 11:56

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome