Mito uneven tyre wear - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Republic of Ireland All events and potential meets in Ireland

 
Thread Tools
(Post Link) post #1 of 5 Old 05-09-11 Thread Starter
Status: -
AO Member
 
Join Date: May 2010
Location: Ireland
County: Cork
Posts: 66
Mito uneven tyre wear

Hi all, I have posted this up on the mito section, though I might as well try here too. The mito went in for its first service and the dealer said the tracking was out leading to the inner part of the tyre wearing away. The 156 used to do this on both front wheels and needed regular adjustment. This is different as it is only the the driver side front. I brought it to a tyre place i regularly use and he was not convinced it is a tracking problem. He seems to think it is the camber or some other set up issue. What do you guys think? Picture included.

All other tyres are wearing normally and very even. The wear is so far over it is almost side wall, its a bit weird to say the least.
Attached Images
File Type: jpg IMG_1117.JPG (51.4 KB, 3 views)
Jak O Shadows is offline  
Sponsored Links
Advertisement
 
Status: BORED
 
David P's Avatar
 
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 85,180
Garage
Did the dealer try to adjust it or just tell you to take it elsewhere to get it sorted

AFAIK the camber isn't adjustable on the Mito as it's set by the casting.
David P is offline  
(Post Link) post #3 of 5 Old 05-09-11 Thread Starter
Status: -
AO Member
 
Join Date: May 2010
Location: Ireland
County: Cork
Posts: 66
He just said to get a new tyre and get the tracking done. I was thinking at the time, methinks he doth protest too much.

Camber isn't adjustable, I think the driver side front might need to be rebuilt.
Jak O Shadows is offline  
Status: Alone in the wilderness
AO Platinum Member
 
Dermo's Avatar
 
Join Date: Aug 2007
County: -
Posts: 13,001

Member car:

Alfa GT 2.0 JTS

All the cars I've owned always wore tyres on the same axel , I have never seen this ( eg the wear you have ) in all the Alfa's and other cars Ive owned . My 147 always wore the tyres on the inside but as the car was on 17s and not the standard 16's it was supposed to come with it was put down to the camber , which is factory set and cannot be changed . I just swapped the tyres from one side to another every 6-7 K miles .. That foooked up when I fitted directional tyres
Dermo is offline  
Status: BORED
 
David P's Avatar
 
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 85,180
Garage
@ Jak : If it was mine I'd be looking to get the Dealer to do the tracking, then if there's a problem again at least they have supposedly already fixed it
David P is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Ireland > Republic of Ireland

Tags
mito , tyre , uneven , wear

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
GT - Uneven rear tyre wear causing excessive noise Rich Alfa 147, 156 & GT 24 18-10-12 08:36
Uneven Tyre Wear - Advice Needed cheungy Alfa 147, 156 & GT 5 01-04-08 14:11
156 uneven rear tyre wear beast Alfa 147, 156 & GT 15 24-06-07 14:26
Front ARB choices DGT Alfa 147, 156 & GT 45 01-06-07 13:36
Really uneven tyre wear on a 159 SW LEZAFLA Alfa 159, Brera & 946 Spider 8 30-05-07 21:50

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome