A newbie - problems already! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Republic of Ireland All events and potential meets in Ireland

 
Thread Tools
(Post Link) post #1 of 6 Old 21-02-10 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2007
Location: Ireland
County: Kildare
Posts: 9

Member car:

Alfa 164

A newbie - problems already!

Hi all,

I'm new to Alfa ownership and hence I'm new to the site. I put this post in the 164 area but I also thought I'd put it in here as I'm in the Republic!

I recently bought a 1993 164 Twin Spark 8v. The car had been lying up for about 3 years. Put a new battery in it and some fresh fuel but it won't fire up. Looks like theres no spark and no fuel getting in either. Not sure if these problems are related of just a coincidence that both spark and fuel are gone? Any ideas?

Also, can someone tell me where the fuel pump and fuel filter are on the car please? Any help would be greatly appreciated.

Thanks,

Paul
pslynam is offline  
Sponsored Links
Advertisement
 
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
Has she got the 2 distributers or has she got the 2 seperate coil packs
 
(Post Link) post #3 of 6 Old 21-02-10 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2007
Location: Ireland
County: Kildare
Posts: 9

Member car:

Alfa 164

Hi,

It appears to be running 2 seperate coil packs, any ideas?

Cheers
pslynam is offline  
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
Well the fuel pump is in the tank
 
(Post Link) post #5 of 6 Old 21-02-10 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2007
Location: Ireland
County: Kildare
Posts: 9

Member car:

Alfa 164

Thanks, so theres nothing that could link the two problems then just a coincidence that there seems to be no spark or fuel?
pslynam is offline  
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
 
Alfa155 TS's Avatar
 
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230

Member car:

75 2.0 8v

Any chance it could be the famous caarbon pixies? on my opel I use to leave her sitting up cause I cycled to work and the cylinders would have a build up of carbon so had to be flushed out (or so the mechanic said) but your car has been sitting up a long time
Alfa155 TS is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Ireland > Republic of Ireland

Tags
newbie , problems

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie: First Alfa and the problems have started already :) davylynne Alfa GTV & 916 Spider 7 26-02-08 19:22
newbie 156 problems!!! And advise. ALFA SHIRE Alfa 147, 156 & GT 1 27-11-07 20:50
Help a Newbie! - Spider engine problems towie Engines (TS, JTS, JTD & V6) 4 08-03-07 17:53
Newbie (well kind of) with problems sggtv Introduce Yourself 8 28-12-06 08:02
Newbie with major Alfa problems Joski Introduce Yourself 12 05-05-06 19:05

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome