trouble starting 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Republic of Ireland All events and potential meets in Ireland

 
Thread Tools
(Post Link) post #1 of 15 Old 31-12-09 Thread Starter
Status: seize the moment, not the engine
AO Member
 
ciarant's Avatar
 
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
ciarant is offline  
Sponsored Links
Advertisement
 
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
More then likely related as a flashing eml light means emissions or timing synchronisation issues if you need any advice just PM me
 
(Post Link) post #3 of 15 Old 04-01-10 Thread Starter
Status: seize the moment, not the engine
AO Member
 
ciarant's Avatar
 
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
just booked it in for Friday morning, will update then, cross fingers, also getting the brakes checked as the pedal is spongy
ciarant is offline  
(Post Link) post #4 of 15 Old 04-01-10 Thread Starter
Status: seize the moment, not the engine
AO Member
 
ciarant's Avatar
 
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
Roughly, How much do you think its costs to replace the cam sensor including labour? and how much to bleed the brakes? €600 is my limit!
ciarant is offline  
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
If you need advice feel free to pm me and I will help with any info
 
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
 
Alfa155 TS's Avatar
 
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230

Member car:

75 2.0 8v

Quote:
Originally Posted by ciarant View Post
Roughly, How much do you think its costs to replace the cam sensor including labour? and how much to bleed the brakes? €600 is my limit!
I was charged something like €300 I think to get mine replaced by a chap near Enfield althought that included an RR session. I have the receipts in work I can post the price on Monday for you
Alfa155 TS is offline  
Status: Smells of Eue De Autoglym
AO Gold Member
 
GTV Gav's Avatar
 
Join Date: Jul 2008
Location: Ireland
County: Kildare
Posts: 6,738

Member car:

'96 GTV TS

Quote:
Originally Posted by ciarant View Post
Roughly, How much do you think its costs to replace the cam sensor including labour? and how much to bleed the brakes? €600 is my limit!
I was charged €34.05 to have my breaks bled including VAT.
GTV Gav is offline  
(Post Link) post #8 of 15 Old 09-01-10 Thread Starter
Status: seize the moment, not the engine
AO Member
 
ciarant's Avatar
 
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
Quote:
Originally Posted by Alfa155 TS View Post
I was charged something like €300 I think to get mine replaced by a chap near Enfield althought that included an RR session. I have the receipts in work I can post the price on Monday for you
Yes that would be great, thanks
ciarant is offline  
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
 
Alfa155 TS's Avatar
 
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230

Member car:

75 2.0 8v

I got my sensor replaced by Don Baker who is based in Johnstownbridge near Enfield. He is an Alfa mechanic. The price for the sensor was €50 and the labour was €150. That included a diagnostic check. Pricey.
My advice would be to look on the web for a cam sensor, you might get it cheaper.
Alfa155 TS is offline  
mo4
Status: back in a 156
AO Member
 
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 731
50 euro is a good price for a cam sensor, and 150 for labour is excellent considering that the belts most likely had to come off to do the job
mo4 is offline  
(Post Link) post #11 of 15 Old 12-01-10 Thread Starter
Status: seize the moment, not the engine
AO Member
 
ciarant's Avatar
 
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
Ill be doing great if i can get it changed for that price, ive been quoted about €300-€400
ciarant is offline  
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
 
Alfa155 TS's Avatar
 
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230

Member car:

75 2.0 8v

well I have the chaps details if you want, its about 45 min drive from Tallaght so thats not bad.
Alfa155 TS is offline  
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
Mark that would have been a crank sensor for that money and not the cam sensor...
 
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
 
Alfa155 TS's Avatar
 
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230

Member car:

75 2.0 8v

hhmmm I'll double check the receipts on Monday Dave, I'm sure it was a cam though. I had a massive loss of power and replacing this brought right back up
Alfa155 TS is offline  
mo4
Status: back in a 156
AO Member
 
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 731
Quote:
Originally Posted by theredx19 View Post
Mark that would have been a crank sensor for that money and not the cam sensor...
Depends on if he took the belts off to change it though
mo4 is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Ireland > Republic of Ireland

Tags
147 , starting , trouble

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome