engine trouble - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Republic of Ireland All events and potential meets in Ireland

 
Thread Tools
(Post Link) post #1 of 4 Old 16-09-09 Thread Starter
Status: -
AO Member
 
yermano's Avatar
 
Join Date: May 2008
Location: Ireland
County: Cork
Posts: 203
Help engine trouble

just a while ago as i was driving home the engine cut out on me 3 times got it started again using a battery booster.
this is what happened on each occasion
pulled up to traffic lights, came to a stop, put in neutral, lights change, put in first , ease off clutch and onto accelerator and engine cuts out and engine managment light comes on not blinking but solid.
hopefully its just a maf sensor thats gone but what esle do ye think it could be?
thanks
bob

ps each time i restarted there were no warning lights( except for the usual ones you get when you turn the ignition) showing while the engine was running the engine management light only comes on after the engine cuts out. they should call it the "something is obviously wrong with the engine light" as it doesnt give a warning and only comes on when something is obviously wrong with the engine

Last edited by yermano; 16-09-09 at 21:03.
yermano is offline  
Sponsored Links
Advertisement
 
Mario Andretti
Status: - Update
Guest
 
Posts: n/a
Sure if you want to pop up on saturday as there is a bit of a pre meet session up in mine, well I am going to try and clean the car out lots of work that....
 
(Post Link) post #3 of 4 Old 16-09-09 Thread Starter
Status: -
AO Member
 
yermano's Avatar
 
Join Date: May 2008
Location: Ireland
County: Cork
Posts: 203
tbh i wouldnt chance it
its a long way from here to there i dont like the though of being stuck in the middle of nowhere broke down waiting on an AA truck
yermano is offline  
(Post Link) post #4 of 4 Old 16-09-09 Thread Starter
Status: -
AO Member
 
yermano's Avatar
 
Join Date: May 2008
Location: Ireland
County: Cork
Posts: 203
mind i wouldnt refuse a lift up on sat il bring some nice whiskey
yermano is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Ireland > Republic of Ireland

Tags
engine , trouble

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
engine trouble kmky Engines (TS, JTS, JTD & V6) 2 07-08-07 12:01
Engine trouble Thiele Engines (TS, JTS, JTD & V6) 2 03-08-07 16:51
Hello me again......Engine Trouble!! Alfa Queen Engines (TS, JTS, JTD & V6) 9 28-06-07 12:34
engine trouble rene Alfa 155 11 16-02-05 07:33

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome