The Selespeed Reliability thread/poll - Selespeed owners ONLY - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Poll Room You got it, just random polls in here

View Poll Results: Your selespeed's reliability
No problems at all 33 44.00%
Minor problems 30 40.00%
Failure 12 16.00%
Voters: 75. You may not vote on this poll

Reply
 
Thread Tools
(Post Link) post #1 of 46 Old 30-10-07 Thread Starter
Status: -
AO Member
 
Join Date: Jun 2005
Location: Australia
County: Queensland
Posts: 640
The Selespeed Reliability thread/poll - Selespeed owners ONLY

Hello all Selespeed owners/drivers,

Following pmptrading's flurry of understandably angry threads, I'm just curious as to the percentage of owners who have actually suffered Selespeed gearbox/system problems. Please vote on the poll.

No problems at all = self explanatory.

By minor problems I mean issues that were easily and inexpensively fixed. The car remained drivable at all times.

By failure I mean something major has gone wrong, leaving the car undrivable. System needed to be fixed/replaced at significant cost.

Please don't let this degenerate into a hoard of comments saying "Selespeed is crap because my mates brothers uncle's one broke once" or "mine has never broken therefore they never ever break". It would be great if we could have a factual record of data. If you want to post anything, put your response and the vehicle's age, condition and milage up.
tremolo is offline  
Sponsored Links
Advertisement
 
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

: : and some.
zulu ferret is offline  
(Post Link) post #3 of 46 Old 30-10-07 Thread Starter
Status: -
AO Member
 
Join Date: Jun 2005
Location: Australia
County: Queensland
Posts: 640
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Does anyone have the intelligence (unlike me) to add a poll?
tremolo is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Japan
County: Tokyo
Posts: 114,689
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Wrong lounge & added poll

BigFoot is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Japan
County: Tokyo
Posts: 114,689
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Voted
BigFoot is offline  
(Post Link) post #6 of 46 Old 30-10-07 Thread Starter
Status: -
AO Member
 
Join Date: Jun 2005
Location: Australia
County: Queensland
Posts: 640
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Sorry and thank-you BigFoot!
tremolo is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Well done administration.: Now, just have to find it?:
zulu ferret is offline  
Status: Wyrd is Life
AO Gold Member
 
Stori's Avatar
 
Join Date: Nov 2002
County: -
Posts: 11,591
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Think this poll needs something about KMs/miles travelled before major failure, if it has occured ..........


The real problem is whether any failure is Km related or not..a low mileage car may neverhave failed because it is exactly that, a low mileage car....

Something like
1) Less than 60,000 kms
No problems at all
Minor problems
Failure

2) more than 60,000 kms
No problems at all
Minor problems
Failure

Last edited by Stori; 30-10-07 at 07:38.
Stori is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Japan
County: Tokyo
Posts: 114,689
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Well, chaps let me know who you want this poll thread to be run and I'll see if I can modify the options above.
BigFoot is offline  
Status: -
AO Member
 
Paddy2bsure's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: Kent
Posts: 683
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Quote:
Originally Posted by tremolo View Post
It would be great if we could have a factual record of data.
*Post removed because I've never owned a Selespeed (nor am i likely to) - apologies*
Paddy2bsure is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

If all things in life were as concerning as a Sele' going wrong, my worries would be zilch.: If it does ever misbehave, well, there are smart guys uk side that are pretty clued up on them, so relax, UK Sele' folk, and get on with life being happy.:
zulu ferret is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,116
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

They're 100% reliable at the moment...

Ralf S.
Ralf S. is offline  
Status: -
 
Join Date: Oct 2007
Posts: 11
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Minor problems. Stalled once, but hey, I still love it.
Rolls Royce don't break down; they "fail to proceed".
schroedinger is offline  
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

I can't see the results unless I vote - and I can't vote
Fraser is offline  
Nev
Status: - Update
Guest
 
Posts: n/a
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Quote:
Originally Posted by Fraser View Post
I can't see the results unless I vote - and I can't vote
Have you tried clicking on "View Poll Results"?


 
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Quote:
Originally Posted by Nev View Post
Have you tried clicking on "View Poll Results"?


Fraser is offline  
Status: -
AO Member
 
JimO's Avatar
 
Join Date: Sep 2006
Location: Surrey
Posts: 191

Member car:

GT V6

Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

I had a 147 2.0L, 02 reg, miles 28k, mint condition, full history, serviced within 3 months and total failure on the actuator.

Cost £2,400 to repair
JimO is offline  
Status: It's the silly season
AO Gold Member
 
GTVDAD's Avatar
 
Join Date: Apr 2007
Location: Plett
County: South Africa
Posts: 9,805
Garage

Member car:

Mito QV

Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

The only problem so far has been a dirty/bad connection to the pump.
Can't say that it was the Sspeed, just an electronic fault
Mine is 2002 with almost 90000km
GTVDAD is offline  
Status: Thirsty for Alfa Knowledge.
AO Member
 
Join Date: Oct 2007
Location: Sydney
Posts: 138
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

2002 147 Selespeed.

Actuator Failure at 66000 Kms (41K miles?) A$3500 (1500 pounds?), two months later the new actuator developed a leak, currently being replaced again under a parts warranty.

Now just hoping all will be well after this.....

Regular maintenance still won't stop things like this happening, but if we wanted a reliable car, we'd buy a Honda. But that's be no fun at all. Give me style and character anytime.

Cheers
TiggerK
TiggerK is offline  
VO2Max
Status: - Update
Guest
 
Posts: n/a
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

80,000 miles trouble-free, seat-of-pants driving. Very occasional (twice in a winter) stalling at very cold temperatures for the 1st 3 changes or so.
 
Status: -
 
Join Date: Aug 2006
Posts: 2
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Just love to retract my vote and vote again...total failure now. Grrhhh. New actuator needed, £1,500 apparently. Just as well my dealer pretty much insisted I took out the 4th and 5th year warranty, because sir, it's not a matter of if the selespeed breaks, just when. Sound advice which I took.
jonlewis is offline  
Status: happier today
AO Silver Member
 
merlin's Avatar
 
Join Date: Jun 2006
Location: Kent
Posts: 2,437
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

4 years and 40 thousand miles on the clock and apart from having it recalibrated it's been fine (touch wood).
merlin is offline  
Status: -
AO Member
 
Rusko's Avatar
 
Join Date: Nov 2007
Location: Preston
Posts: 55
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Only owned her for 2 months. I've been told synchro has worn on 3rd so going to Ferdi's in Lytham to check it out.

Apart from that its bloody great!!!
Rusko is offline  
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,082
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

I am not likely to own one, apart from being worried about it going wrong I prefer the driving experience of a manual..
symon is offline  
Status: -
AO Silver Member
 
GTACharlie's Avatar
 
Join Date: Dec 2004
Location: Tokyo, Japan
Posts: 1,878
Re: The Selespeed Reliability thread/poll - Selespeed owners ONLY

Drove my 147 GTA Selespeed for 50,000 gloriously hard-driven km over three years. Though not perfect in slow driving, the thing is an absolute work of art when pushed. Never once had a problem with her and now that I am in an Alpina with the Switchtronic transmission, I find myself missing the Selespeed's amazingly fast shifts and perfect throttle blips almost ever single day
GTACharlie is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > Poll Room

Tags
owners , reliability , selespeed , thread or poll

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome