A sad sight... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
North Scotland All events and potential meets in North Scotland

 
Thread Tools
(Post Link) post #1 of 16 Old 13-07-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
A sad sight...

Had the 159 for 2 weeks to the day and that's it being towed away to Western Alfa in Perth.

It's developed a judder / misfire and an increase in oil level.

Attached Images
File Type: jpg image.jpg (68.9 KB, 44 views)
kevbhoy75 is offline  
Sponsored Links
Advertisement
 
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

Possible injector fault..
Mito_No3 is offline  
Status: Paint it black
AO Member
 
INS147's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551

Member car:

Alfa-less

This will sound strange.... but did you smell or sniff the oil before it left for Western
INS147 is offline  
(Post Link) post #4 of 16 Old 14-07-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
Quote:
Originally Posted by INS147 View Post
This will sound strange.... but did you smell or sniff the oil before it left for Western
No I didn't. But, this will also sound strange, I thought there was a smell not unlike aircraft fuel from the car. Never had a smell like that from a car!
kevbhoy75 is offline  
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

I'm too busy next week I think, so prob won't be me looking at it....
Mito_No3 is offline  
(Post Link) post #6 of 16 Old 14-07-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
Quote:
Originally Posted by GT_MitoOwner View Post
I'm too busy next week I think, so prob won't be me looking at it....
Laura and Willie know about it as I was in past a week past Wednesday and Willie took it for a drive to see what the problem was. I'll give them a call in the morning.
kevbhoy75 is offline  
Status: Paint it black
AO Member
 
INS147's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551

Member car:

Alfa-less

Quote:
Originally Posted by kevbhoy75 View Post
No I didn't. But, this will also sound strange, I thought there was a smell not unlike aircraft fuel from the car. Never had a smell like that from a car!
Indeed! Only reason I ask is I recently saw an Audi diesel getting packed off to a scrappers as the owner mysteriously found more oil in his sump. He was running a diesel tuning box (ebay special) which had given him big power but (quote) "loads and loads of crappy black smoke". On sniffing the dipstick it was clear the sump was full of oil/diesel mix. Now I've come across that sort of bore-wash before (on a Range Rover V8 - fuel in sump) but never on a diesel.

I've wondered how it was possible on a turbo diesel unless it was seriously seriously over-fuelling and fuel was just being blown down into the sump

Anyway, hope it's not that serious for you and is quickly fixed

Ocht
INS147 is offline  
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

Quote:
Originally Posted by kevbhoy75 View Post
Laura and Willie know about it as I was in past a week past Wednesday and Willie took it for a drive to see what the problem was. I'll give them a call in the morning.
Willie is on 2 weeks holiday just now. I remember seeing the car before now that I have seen it in the compound.
Mito_No3 is offline  
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

Sure I seen it in the workshop this morning. Don't know what the outcome was though
Mito_No3 is offline  
(Post Link) post #10 of 16 Old 17-07-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
Quote:
Originally Posted by GT_MitoOwner View Post
Sure I seen it in the workshop this morning. Don't know what the outcome was though
Yes it was. They've opened a case with Alfa Technical. Oil level way over the max again so oil, filter and forced re-gen is the first port of call.
kevbhoy75 is offline  
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

Quote:
Originally Posted by kevbhoy75 View Post
Yes it was. They've opened a case with Alfa Technical. Oil level way over the max again so oil, filter and forced re-gen is the first port of call.
Yea seen the Tech doing the oil and filter change today then going for road test, Sure its back on the ramp again though. Place is really busy just now, no time to stop for a sec this week
Mito_No3 is offline  
(Post Link) post #12 of 16 Old 18-07-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
Quote:
Originally Posted by GT_MitoOwner View Post
Yea seen the Tech doing the oil and filter change today then going for road test, Sure its back on the ramp again though. Place is really busy just now, no time to stop for a sec this week
Yeah it broke down on the road test and had to be recovered! Fuel pump ordered from Italy on a "first time fit" (4 day delivery) so they can return it if it's not that. Going to stretch into next week now
kevbhoy75 is offline  
Status: Paint it black
AO Member
 
INS147's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551

Member car:

Alfa-less

Any update
INS147 is offline  
(Post Link) post #14 of 16 Old 19-08-13 Thread Starter
Status: the Alfa might have to go this year!
AO Member
 
kevbhoy75's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Aberdeen
Posts: 45
Yes. I got the car back on Wednesday after 4 1/2 weeks in Western. It was the sensor on the fuel rail which was causing the car to over fuel which led to an increase in the oil level, blocked DPF and clogged exhaust!
kevbhoy75 is offline  
Status: Paint it black
AO Member
 
INS147's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551

Member car:

Alfa-less

I'm very pleased to hear you've got it back
INS147 is offline  
Status: Mabe just mabe this time.
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,255

Member car:

Mito 1.6JTDM

Glad you got it fixed in the end was off for 2 weeks there so missed the final outcome..
Mito_No3 is offline  
Reply

Go Back   Alfa Romeo Forum > Alfa Romeo Club Events > Alfa Romeo Meets & Events > Scotland > North Scotland

Tags
sad , sight

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome