HELP!connect nav+ firmware,fiat forum knows more than us!!! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 6Likes
Reply
 
Thread Tools
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by rene147 View Post
Hi, been following this thread fro ages now! do i have to take my car to the dealers to get this done? or is it possible to download the update from somewhere?

Cheers,
Rene
It's possible to get it, but don't know where.
I have it on my pc and don't know if can be posted here.

Who wants setup cd and software updater let me know on pm or mail matej (a) trije (dOt) com - rather on mail, becouse i have trouble logging to AO forum (don't know why, but need to reset my pass everytime...).

Take care,
M.
wodp is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
rene147's Avatar
 
Join Date: Jul 2006
Location: Northampton
Posts: 69

Member car:

147

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Hi, you can take a ISO image of the disk (or if you already have it stored on your PC then no need) basically its just a copy of the disk! Then upload the file to something like RapidShare: 1-Click Webhosting then that’s it we can all download it from that site!

If none of that makes sense let me know I can explain in more detail!

Cheers,
Rene
rene147 is offline  
Status: -
Admin Team
 
Alfa Vincent's Avatar
 
Join Date: Nov 2005
Location: United Kingdom
County: Hertfordshire
Posts: 30,408
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

I would just like to add my interest to this. I really want to get Aux in sound working - I have got the cd changer Aux in adaptor but it doesnt seem to recognise when its connected. Anyone know if an update might fix this??
Alfa Vincent is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Ok this is how i made.
First i need to say that you're doing everything on your own risk!!

I have 2006 Alfa 147 and it works on Connect Nav+. Friend tried on earlier 2003 version and it didn't work on his (Cd stucked in player!).

I warn you... it's your decision.

1. check your current firmware version
Help here:

2. if it's x.yy it's newer system, older have xx.yy
I had 4.07 and updated to 5.0 (MP3 support)

3. my car was turned off while updating, so turn on only CNS (connect nav sys) and insert update cd.

- update cd for x.yy (newer system can be downloadad from this location:

Password: alfaklubsi

Older version is here:

Password: alfaklubsi - BUT I WARN YOU... My friend couldn't upgrade and he had serious problems with it!! If someone has sucessfully updated please share with us!

- burn iso with some burner (i used nero - at lowest speed and DAO: disc at once)

4. insert cd and you get error cd message (radio can't play it, that's normal).

5. restart CNS with cd left in.

6. it should boot from it now and start updating process.



! Few times it got to 50% and it looked that it's stucked. I tried everything to remove cd and cancel update. Than when i almost lost my nerves, i just left it to cycle and restart CNS again and again... After 20minutes when i got back in the car it vas already 70% and than 90% and finally finished. Cd got out itself!

7. after cd out, restart CNS and wait some time.
(first boot is much longer than usual)

8. Than i tried MP3 cd:



... and checked FW version:



Update was sucessful.

WARNING: after updating i couldn't change VR (voice recognition) language to English, all others work (French, German,Dutch, Italian, Spanish...) Just ENG not.

There are some informations about even newer SW version 5.2 which would repair this and also allow to skip songs for more than one a time.

To skip more songs, i use shuffle.
Also 5.2 should have improved when you turn on car, it goes from where you've stopped before. It's annoying to always start at song 1 on mp3 cd!!
I hope they will fix such small but stupid software problems.


DON'T BLAME ME IF YOU'LL GET FAULT ON CNS!! I just reported how i updated my CNS.

But i hope you've managed to update it.It's so nice to listen to MP3's while driving such car. Cuore sportivo ftw

Regards,
M.
wodp is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by Alfa Vincent View Post
I would just like to add my interest to this. I really want to get Aux in sound working - I have got the cd changer Aux in adaptor but it doesnt seem to recognise when its connected. Anyone know if an update might fix this??

Sorry wouldn't know about this...
wodp is offline  
Status: Fingers crossed
AO Member
 
Join Date: May 2007
Location: United Kingdom
County: Hampshire
Posts: 363

Member car:

Brera 2.2 S

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by wodp View Post
Ok this is how i made.
First i need to say that you're doing everything on your own risk!!

I have 2006 Alfa 147 and it works on Connect Nav+. Friend tried on earlier 2003 version and it didn't work on his (Cd stucked in player!).

I warn you... it's your decision.

1. check your current firmware version
Help here:

2. if it's x.yy it's newer system, older have xx.yy
I had 4.07 and updated to 5.0 (MP3 support)

3. my car was turned off while updating, so turn on only CNS (connect nav sys) and insert update cd.

- update cd for x.yy (newer system can be downloadad from this location:

Password: alfaklubsi

Older version is here:

Password: alfaklubsi - BUT I WARN YOU... My friend couldn't upgrade and he had serious problems with it!! If someone has sucessfully updated please share with us!

- burn iso with some burner (i used nero - at lowest speed and DAO: disc at once)

4. insert cd and you get error cd message (radio can't play it, that's normal).

5. restart CNS with cd left in.

6. it should boot from it now and start updating process.



! Few times it got to 50% and it looked that it's stucked. I tried everything to remove cd and cancel update. Than when i almost lost my nerves, i just left it to cycle and restart CNS again and again... After 20minutes when i got back in the car it vas already 70% and than 90% and finally finished. Cd got out itself!

7. after cd out, restart CNS and wait some time.
(first boot is much longer than usual)

8. Than i tried MP3 cd:



... and checked FW version:



Update was sucessful.

WARNING: after updating i couldn't change VR (voice recognition) language to English, all others work (French, German,Dutch, Italian, Spanish...) Just ENG not.

There are some informations about even newer SW version 5.2 which would repair this and also allow to skip songs for more than one a time.

To skip more songs, i use shuffle.
Also 5.2 should have improved when you turn on car, it goes from where you've stopped before. It's annoying to always start at song 1 on mp3 cd!!
I hope they will fix such small but stupid software problems.


DON'T BLAME ME IF YOU'LL GET FAULT ON CNS!! I just reported how i updated my CNS.

But i hope you've managed to update it.It's so nice to listen to MP3's while driving such car. Cuore sportivo ftw

Regards,
M.

thanks for the info but the links don't seem to be there?

Anyone tried this successfully on an Alfa 147 2002 Connect+?

What is likely to happen to my system if the upgrade fails...?

TIA
jamezm is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

How to turn on html codes?

Links are:

NEW CNS SYSTEM:
2shared - file upload

OLDER ONE:
2shared - file upload

And than SETUP cd: to change language (ENG VR doesn't work)
2shared - file upload


Passwords are all the same: alfaklubsi

@Tia: cd can stuck in CNS and it won't boot up (no music in car). It's better to wait for someone to report sucess. We tried on one alfa GT 2004 system and it stucked cd (it's on servis now to get it out).

M.
wodp is offline  
Status: -
AO Member
 
Join Date: Dec 2007
Location: Swansea
Posts: 20
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Thx for the Software update as yet have not tried it. My framewire is 23.13 (52 plate)the down load file is 23.16 do we know if this is the latest framewire update
spin36 is offline  
jwq
Status: driving Giulia Veloce AWD
Club Member
Membro Premio
 
jwq's Avatar
 
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 6,564
Garage
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by spin36 View Post
Thx for the Software update as yet have not tried it. My framewire is 23.13 (52 plate)the down load file is 23.16 do we know if this is the latest framewire update
26.15 (or 26.16?) is the latest in that range...
jwq is offline  
Status: -
Newbie
 
Join Date: Apr 2008
Posts: 1
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Hi,

yes, newest version for the "older" (probably before 2004) Connect NAV+ is 26.16

That update appears to be from 2004.

Anyone by chance knows what has been changed in 26.16 from 26.15 ?
I'm thinking about updating, but I don't want to make things worse

It looks like version numbers are often confused.

The version in the second previous post from wodp for the older systems is not 23.16 as the filename says, but 26.13
Which therefore is not the newest one, which is 26.16

I hope this is helpful to anyone


One more thing considering the mp3 upgrade:

As already stated, it works only if you have version 4.xx or 5.xx which is believed to apply to units from 2004 or later.
Mine is production date 2003-03 (can be seen on the same screen as the version) and still is the old 26.xx variant.

Apparently those new units had something changed on internal hardware and mp3 upgrade only works on those.
Hoegen is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Thanks for clarification. Didn't know exactly for old systems.

Anybody knows about 5.2 update?? it should have repaired last song played and such stuff... i don't remember where i read that.

Anyone?

Take care for Alfas
M.
wodp is offline  
Status: -
AO Member
 
Join Date: Feb 2008
Posts: 32
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Are any of you guys able to point me in the direction of a Connect+ 'set-up cd' disc, image or file for the 147 at all please? - one which WILL allow me to change the language back to english aswell.

We have been trying to find where the master code is stored in these units for the last 9 weeks (seems to be in one of the secured BGA flash devices) and every 3 or 4 attempts to read, modify, re-read the data, results in the unit reverting back to Italian language.

I am aware that the launguge can be changed via the dash mounted computer but this can only be done after the unit has been 'married' to a car with the master code

Doesn't have to be a freebie, more than happy to pay for it if somebody knows the link

Thanks in advance
audiotech is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by audiotech View Post
...
Doesn't have to be a freebie, more than happy to pay for it if somebody knows the link

Thanks in advance

Check my post #32 (few posts up) for SETUP CD.


Regards,
M.
wodp is offline  
Status: -
Newbie
 
Join Date: May 2008
Posts: 1

Member car:

Stilo

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

For those of you with updates that fail, there is a procedure that works on Fiat Connect Nav's and probably Alfa's too (but I have not tried) to restart it. Turn the unit on after it has failed and press 2, 3, 4, 5, 6, TEL and the display lights should flash 3 times, then update will restart.
john55 is offline  
Status: Quo
AO Member
 
efcmandan's Avatar
 
Join Date: Aug 2004
Location: North-West UK
Posts: 609

Member car:

335i

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Nice info on here. When I get my car, hopefully on Saturday, I'll try and get to Mango's and see if they'll update the Connect Nav+ for free. If they will, I'll somehow try and 'borrow' the CD and image it on my laptop.

Last edited by efcmandan; 01-06-08 at 12:26.
efcmandan is offline  
Status: -
Newbie
 
Join Date: May 2008
Posts: 5
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Hi..

I bought a new alfa romeo 147 exclusive 2007 and i have from the manufacturer installed CNS version 5.0....but unfortunately no MP3 playing..

I didn't do the update which is described here because the car already have version 5.0

I cannot understand what is going wrong...
Please help..

Thanks a lot!!
Stef_a147 is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

That's interesting. Have you asked your seller or maybe on official servis? If you get any info about CNS software ver 5.2 please let us know... try different mp3 cd's - maybe without folders. just mp3s on cd...

others, i don't know why isn't playing....

WODP
wodp is offline  
Status: -
Newbie
 
Join Date: May 2008
Posts: 5
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

thnks for your advice..

I will contact with the service team and if i have a new CNS version i will inform you immediately.
Stef_a147 is offline  
Status: -
Newbie
 
Join Date: Jun 2008
Posts: 7

Member car:

147

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

How is the procedure to finde out what version of update is installed???

I have to admit, that I messed my update up - now I am not sure if I took the wrong version of update or if the cd was burned to fast. I only know that the car was sold 2004/8 and the navi was changed in 2007 (had a problem with the telefonfunktion)

now I will try the 2, 3, 4, 5, 6, tel trick (dealer got the cd out - do not know how?)

Stefan
da'stefano is offline  
Status: -
Newbie
 
Join Date: Jun 2008
Posts: 1

Member car:

Alfa 147 JTD

Madness Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

@wodp,
I've tried to download the nrg files but when i try to burn them with Nero 7 is failed after verifying the data.
Do u know how to fix this?

Edit:
I've burn the nrg file now with ImgBurn and now i've update the nc+. Thnx a lot for all the information here.

Last edited by JesusPassion; 27-06-08 at 15:05.
JesusPassion is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by JesusPassion View Post
@wodp,
I've tried to download the nrg files but when i try to burn them with Nero 7 is failed after verifying the data.
Do u know how to fix this?

Edit:
I've burn the nrg file now with ImgBurn and now i've update the nc+. Thnx a lot for all the information here.

Nice to hear sucessful update! Much fun with mp3s
wodp is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

Quote:
Originally Posted by da'stefano View Post
How is the procedure to finde out what version of update is installed???

I have to admit, that I messed my update up - now I am not sure if I took the wrong version of update or if the cd was burned to fast. I only know that the car was sold 2004/8 and the navi was changed in 2007 (had a problem with the telefonfunktion)

now I will try the 2, 3, 4, 5, 6, tel trick (dealer got the cd out - do not know how?)

Stefan
Stefano, check here: Alfa Romeo 147 ConnectNav+ Informations

Hope it helps!
WODP
wodp is offline  
Status: -
Newbie
 
Join Date: Jul 2008
Posts: 5

Member car:

Alfa147 (08)

Help HELP!Alfa romeo told me that they can't fix my connect nav+

Hello everyone....
I own an new Alfa147 exclusive since the first day of 2008
...but i was so bored with normal cd's so a started searching about updating my connect nav+ and that's how i've found you.
Sadly i've tried to update as your orders but the upgrade always stuck either at 20+ or 50+......
So i had no other choise but going my car to service...
but there these bunch of clowns told me that they can't do anything!!
my first expression was like
my second was like
and now i'm like
Please help me!!!!!!!!!!!!!
piper21 is offline  
Status: -
AO Member
 
wodp's Avatar
 
Join Date: Sep 2007
Location: Slovenia
Posts: 18
Re: HELP!Alfa romeo told me that they can't fix my connect nav+

Quote:
Originally Posted by piper21 View Post
Hello everyone....
I own an new Alfa147 exclusive since the first day of 2008
...but i was so bored with normal cd's so a started searching about updating my connect nav+ and that's how i've found you.
Sadly i've tried to update as your orders but the upgrade always stuck either at 20+ or 50+......
So i had no other choise but going my car to service...
but there these bunch of clowns told me that they can't do anything!!
my first expression was like
my second was like
and now i'm like
Please help me!!!!!!!!!!!!!
Post #39 = not helping?
how did you burn cd (mostly bad cd's are reason of failure)?
did you check cns software before?
how long have you tried updating?

if you answer, i'll try to help you in few days, depends if there will be internet where im going...

take care,
wodp
wodp is offline  
Status: -
Newbie
 
Join Date: Jul 2008
Posts: 5

Member car:

Alfa147 (08)

Re: HELP!connect nav+ firmware,fiat forum knows more than us!!!

it really doesn't (post 39)
i burned it at 8x with nero..
i didn't check cns software before
unfortunately i've tried updating for many hours.....
now i'm waiting for a call from service... they 've send the connect+ at blaupunkt...i really can't undestund why.... anyway hope you give me some help....

Last edited by piper21; 21-07-08 at 19:20.
piper21 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > ICE & Blue&Me

Tags
fiat , firmware , forum , helpconnect , nav

« 33 i.c.e | - »
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome