Oops.. Wrong car! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
General Alfa Discussion Strictly Alfa Romeo talk only!

 
Thread Tools
(Post Link) post #1 of 5 Old 12-09-13 Thread Starter
Status: -
AO Member
 
William Carr's Avatar
 
Join Date: Aug 2013
Location: Norway
County: Østfold
Posts: 164

Member car:

156 - 98 MODEL

Oops.. Wrong car!

Today I waved to a passing Alfa while I was driving my Mazda. Duh! ;-)

William
William Carr is offline  
Sponsored Links
Advertisement
 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Japan
County: Tokyo
Posts: 114,689


Good effort mate!
BigFoot is offline  
Status: R.I.P Paula :(
AO Rosso Alfa Member
 
Shant Ole's Avatar
 
Join Date: Dec 2009
Location: Cyprus
County: Larnaca
Posts: 57,683




Shant Ole is offline  
Status: Molto felice
AO Rosso Alfa Member
 
Gibbo's Avatar
 
Join Date: Oct 2004
Location: United Kingdom
County: Bristol
Posts: 54,872
I keep going to do that when in my van



Gibbo is offline  
Status: The Rosso twins are here!
AO Silver Member
 
edraven71's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 3,852
Garage
I did it in my van once and strangely got a wave back.

Probably thought I was on day release or something
edraven71 is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > General Alfa Discussion

Tags
car , oops , wrong

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome