Alfa 156 - the worst car I have ever owned - Alfa Romeo Forum
You are currently unregistered, register for more features.    
General Alfa Discussion Strictly Alfa Romeo talk only!

Reply
 
Thread Tools
(Post Link) post #1 of 97 Old 24-06-08 Thread Starter
Status: -
 
Join Date: Nov 2006
Posts: 25
Alfa 156 - the worst car I have ever owned

...discuss
percy5095 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
injunfighter's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Norfolk
Posts: 498
Re: Alfa 156 - the worst car I have ever owned

Quote:
Originally Posted by percy5095 View Post
...discuss
On here?
Don't think that will be much of a discussion...
Maybe you could start us off?
injunfighter is offline  
Status: enjoying ma julie
AO Silver Member
 
belfast bob's Avatar
 
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
Re: Alfa 156 - the worst car I have ever owned

worst for sleepless nites and opening wallet

best for everything else - every rose has its thorn

when you buy an alfa/156 you realise most other cars are merely boxes on wheels
belfast bob is offline  
Status: i don't use fuelly
AO Platinum Member
 
nigelread's Avatar
 
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,305
Re: Alfa 156 - the worst car I have ever owned

nigelread is offline  
Status: Back to Alfa
AO Silver Member
 
Dougie166's Avatar
 
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,150

Member car:

Giulietta QV

Re: Alfa 156 - the worst car I have ever owned

I have owned two 156's - Both a joy to own.

My first was a 1999 1.8 SP1 saloon (I bought it at just under 2 years old) - Only issue was front top balljoints but got majority paid by Alfa. I owned the car for around 9 or 10 months and then sold for a profit!

My second was a 2001 1.8 SP3 Sportwagon (I bought it at 18 months old) - Never had any issues with this car and owned it for 4 years. Sold it to a friend who is still enjoying it.

I respected these cars and kept them well serviced so all Ok

Gone but not forgotten - 164 3.0 12v - 156 1.8 SP1 - 164 3.0 24v - 156 SW 1.8 SP3 - 166 Super - 166 3.2 Ti - Brera SV JTDM - 156GTA - 147GTA - 147GTA - 156GTA. Current Giulietta QV
Dougie166 is offline  
Status: -
AO Member
 
BigGinge's Avatar
 
Join Date: Sep 2006
Location: United Kingdom
County: Oxfordshire
Posts: 958
Re: Alfa 156 - the worst car I have ever owned

I've never owned one.
BigGinge is offline  
Status: Daddy bear
Global Mod Team
 
bazza's Avatar
 
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 44,629

Member car:

AMG C63 estate

Re: Alfa 156 - the worst car I have ever owned


If you're trying to be controversial, at least say something worth talking about.

If you're actually trying to make a point, then tell us what it actually is.
bazza is online now  
Status: -
 
Join Date: Jun 2008
Posts: 1
Re: Alfa 156 - the worst car I have ever owned

every thing ok, until today! Fault with ECM/PCM processor. She wouldn't start. Anybody had sim prob?
torinese is offline  
Status: -
 
Join Date: Mar 2008
Posts: 236
Re: Alfa 156 - the worst car I have ever owned

No ones asked the most obvious question yet...how many cars have you owned?
6miester is offline  
Status: -
AO Member
 
AntMat's Avatar
 
Join Date: Jun 2007
Location: SW France
Posts: 267
Re: Alfa 156 - the worst car I have ever owned

The worst car I ever owned was an Audi-NSU RO 80. I have owned 33 cars. This was closely followed by a Chevrolet Corvair Corsa John Fitch Sprint!
AntMat is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,901
Re: Alfa 156 - the worst car I have ever owned

Quote:
Originally Posted by torinese View Post
every thing ok, until today! Fault with ECM/PCM processor. She wouldn't start. Anybody had sim prob?
Could be anything mate, start a thread on it in the technical lounge for best response
Pud237 is online now  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 30,126
Re: Alfa 156 - the worst car I have ever owned

It was the worst car I ever had as I don't think anything will ever come close as a complete driving package As nice as the Ti is, I still really miss mine
Squadrone Rosso is offline  
Status: Spider's on the road.
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,965
Garage
Re: Alfa 156 - the worst car I have ever owned

Moved to General Alfa discussion or is this a rant?
classicgal93 is offline  
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Re: Alfa 156 - the worst car I have ever owned

My 156 (post facelift 2.4JTDm Veloce) was one of the best cars I've owned, only let down by its propensity to scrape its bottom on the road.
Fraser is offline  
Status: Wants a 147! :)
AO Silver Member
 
stu_the_flat's Avatar
 
Join Date: Oct 2007
Location: United Kingdom
County: Glasgow
Posts: 3,436
Re: Alfa 156 - the worst car I have ever owned

If you've got a bad example (Of any car) Your going to hate it.
stu_the_flat is offline  
Status: 159 Hunted......
AO Platinum Member
 
dpat's Avatar
 
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,436
Re: Alfa 156 - the worst car I have ever owned

I loved my 1.8 TS 156
dpat is offline  
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Re: Alfa 156 - the worst car I have ever owned

Quote:
Originally Posted by stu_the_flat View Post
If you've got a bad example (Of any car) Your going to hate it.
I was going to agree and then I remembered my 166. Despite everything that went wrong (and I mean everything!) I still loved it. Difference was the after-market warranty I bought paid for almost all of the repairs.
Fraser is offline  
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,091
Re: Alfa 156 - the worst car I have ever owned

All of my 156's have been great cars.(in fact all of my Alfa's have)
The worst car I have owned was a Rover Vitesse Sport, and the second worst a Nissan 200SX (s14)
symon is offline  
Status: only got a renault truck
AO Silver Member
 
jason156's Avatar
 
Join Date: May 2007
Location: United Kingdom
County: Powys
Posts: 3,013
Re: Alfa 156 - the worst car I have ever owned

Best car I have owned
Cross country on back roads = to or better than BMW 3 series
Performance and acceleration = better than a 5.7 chevy
Fuel economy= better than a 5.7 chevy
Style and interior spec. top car leather aircon leccy windows and the loud pedal, lovely quick steering
Unbeatable
jason156 is offline  
Status: V6 Inside
AO Silver Member
 
ransoman's Avatar
 
Join Date: Jan 2007
Location: United Kingdom
County: Aberdeenshire
Posts: 4,881
Re: Alfa 156 - the worst car I have ever owned

If your last car was a Ferrari 430 then yes, the 156 would be the worst car you have ever owned.
ransoman is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,901
Re: Alfa 156 - the worst car I have ever owned

Quote:
Originally Posted by Fraser View Post
My 156 (post facelift 2.4JTDm Veloce) was one of the best cars I've owned, only let down by its propensity to scrape its bottom on the road.
How many sumps did you go through?

I agree, having such a tall engine mounted so low at the front, without a proper suspension set-up is a real bad thing. My JTD suffered for it, the V6 isn't as bad but you can still feel that it is nose heavy.
Pud237 is online now  
Ferryman_1957
Status: - Update
Guest
 
Posts: n/a
Re: Alfa 156 - the worst car I have ever owned

Quote:
Originally Posted by percy5095 View Post
...discuss
I don't know what other cars you've owned......

Cheers,

Nigel
 
Status: -
AO Member
 
Join Date: Apr 2008
Location: keswick,lake district
Posts: 18

Member car:

156 2.5 v6

Re: Alfa 156 - the worst car I have ever owned

im on my second 156 2.5 v6 in 3 months.1st one decided on terminal engine failure,not cambelt either cos i had just spent 1400 quid at main dealers on both belts all idlers and tensioners and waterpump and a couple of odds and sods.also treated it to new maf sensor,both top wishbones, shocks on all 4 corners ,both rear hand brake cables ,thermostat ,2 new rear tyres and a 200 quid dvd/cd .about 3500 pound including initial cost of 1200 pound for car.to say i was nearly physically sick when it popped its clogs is an understatement..cheered my self up by buying my second one .at least ive now got a bountifull supply of spares.worst car?no chance,best car ive driven..bloody expensive to maintain though..especially 9/10 year old ones..interestingly my second one needed maf sensor,thermostat,top wishbones and suspension all round and temp guage went on blink,lots of part changing going on..good therapy methinks..madness is only part of the disease..
trancepants5 is offline  
Status: -
AO Member
 
gechman's Avatar
 
Join Date: Jan 2008
Posts: 158

Member car:

Brera 2.4SV

Re: Alfa 156 - the worst car I have ever owned

i've had two Fiat Coupes...need I say more!

Battle hardened!
gechman is offline  
Status: -
AO Member
 
MORGANO's Avatar
 
Join Date: Apr 2008
Location: Chelmsford, Essex
Posts: 73
Re: Alfa 156 - the worst car I have ever owned

I loved mine, it did me proud, and amazingly never had a problem! It's only been gone 4 weeks but every time I see one like my old one on the road I smile and remember the days lol. Now got a Spider LE, so can't complain as I love that too!
MORGANO is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > General Alfa Discussion

Tags
156 , alfa , car , owned , worst

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome