Twinspark Waterpump Leak! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
General Alfa Discussion Strictly Alfa Romeo talk only!

 
Thread Tools
(Post Link) post #1 of 1 Old 03-06-08 Thread Starter
Status: saving for a 3200GT
AO Member
 
midlifecrisis's Avatar
 
Join Date: Aug 2007
Location: United Kingdom
County: Swansea
Posts: 908
Looky Looky Twinspark Waterpump Leak!

I had my cambelt, tensioner, idler and variator changed today at N-J-S in Pershore. When the guy took off the covers and stripped the belts he noticed that my waterpump had been slowly leaking coolant on the belt and tensioner Needless to say the waterpump has also been changed!

I had topped up the coolant recently and had a good look at all the seals and pipes but could not see any leaks or evidence of leaks. Just thought it was maintenace issue.

From what N-J-S said I have been lucky. They had a 3 litre GTV in the workshop with a snapped belt and a bill for 2 grand waiting for the owner

My 147 is 3 1/2 years old and less than 20000 miles but I still had the cambelt work done. Im glad i did now.

I just thought i would share this with you guys. If your coolant seems to be going down slowly then it could be your waterpump that is leaking onto your cambelt

By the way N-J-S were excellent with the work they did on the car and the amount they charged! Recommended
midlifecrisis is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > General Alfa Discussion

Tags
leak , twinspark , waterpump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome