147 Selespeed failure oh dear oh dear...... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
General Alfa Discussion Strictly Alfa Romeo talk only!

 
Thread Tools
(Post Link) post #1 of 2 Old 17-01-08 Thread Starter
Status: -
 
Join Date: Nov 2007
Posts: 8
147 Selespeed failure oh dear oh dear......

Just round new year I started to get "selespeed system failure" warnings up on the dash, fortunately I was only a mile or so from home so limped back.

The garage has now had the car for over 2 weeks and at first said it was probably a gearbox pump, now their saying its def the actuator thats at fault and the part alone is best part of 900 quid and probably all in about £1500 to fix.

To say im now f*cked off with this car is an understatement! Dont get me wrong when its working its fine and I love it but in the 2.5 years Ive owned it it going to have cost me over £3000 in repairs (cam belt went too just over a year ago....) and for a car which is ony just coming up to 5 years old thats not really on........I think its time to get rid of it and go for something a bit more sensible.......

Soes anyone have and similar thoughts sometimes..........??
Liverpool-147 is offline  
Sponsored Links
Advertisement
 
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,079
Re: 147 Selespeed failure oh dear oh dear......

They do say that its more of a case of when the selespeed system goes wrong than if, hence why many people on here won't go near one.

Cambelts have also been an issue, Alfa has since reduced the service interval to 36,000 miles from 72,000.

I have had loads of Alfa's, and none of them have let me down badly, although none of them were selespeeds.

I have had other makes of car that have let me down, including Nissan, Rover and Ford.
symon is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > General Alfa Discussion

Tags
147 , dear , failure , selespeed

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome