147 Engine help!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 12 Old 18-12-07 Thread Starter
Status: -
AO Member
 
ktulu123's Avatar
 
Join Date: Mar 2007
Location: Ireland
County: Wicklow
Posts: 70
147 Engine help!!!

Im just wondering if the cracks on this part of my engine are serious! If so could you let me know some details about it,

Thanks
Attached Images
File Type: jpg 18122007890.jpg (54.7 KB, 31 views)
File Type: jpg 18122007891.jpg (68.6 KB, 21 views)
ktulu123 is offline  
Sponsored Links
Advertisement
 
alfa_147_jtd_16v
Status: - Update
Guest
 
Posts: n/a
Re: 147 Engine help!!!

Depends what you class as serious......its just the heat shield cover for the exhaust so its not even the engine!
Whats the worst that can happen? it breaks and you need a new heat shield!
 
Status: Has tha nowt moist?
AO Silver Member
 
dxechick's Avatar
 
Join Date: Jan 2006
Location: United Kingdom
County: North Yorkshire
Posts: 3,567

Member car:

Black 159

Re: 147 Engine help!!!

I think they all do it,mine is worse than that
dxechick is offline  
Status: Quieter now...
AO Member
 
RBaron's Avatar
 
Join Date: Nov 2007
Location: Lutterworth, UK
Posts: 305
Re: 147 Engine help!!!

I had the similar 1.6 engine in my 145. My heatshield disappeared at about 30k miles. No ill effects at 150k.
RBaron is offline  
Status: 3,75 running great :)
AO Car Of The Year Winner 2015
Membro Medio
 
gotcha's Avatar
 
Join Date: Dec 2003
Location: Slovakia
County: Bratislavsky
Posts: 3,202
Re: 147 Engine help!!!

It may continue cracking slowly and eventually start to rattle so you will have to remove or replace it.
gotcha is offline  
(Post Link) post #6 of 12 Old 18-12-07 Thread Starter
Status: -
AO Member
 
ktulu123's Avatar
 
Join Date: Mar 2007
Location: Ireland
County: Wicklow
Posts: 70
Re: 147 Engine help!!!

thank god, i was thinking it was gonna be a big job costing lots of money!

cheers
ktulu123 is offline  
Status: -
 
Join Date: Nov 2005
Posts: 233
Re: 147 Engine help!!!

My 147 did that. Really sounded bad. Cost £40 for a new one fitted at a local Alfa Indie. Easy.
Dai Alfa is offline  
Status: -
 
Join Date: Nov 2005
Posts: 233
Re: 147 Engine help!!!

Did your undertray fall off? No sign of it in the picture.
Dai Alfa is offline  
Status: Taking it to bits.
AO Platinum Member
 
RicksAlfas's Avatar
 
Join Date: Sep 2002
Location: West Yorkshire
Posts: 17,177

Member car:

1750 GTV

Drunk Re: 147 Engine help!!!

The first pic looks like a really sad face....
RicksAlfas is offline  
jug
Status: -
AO Silver Member
 
jug's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Re: 147 Engine help!!!

wow it really does!
jug is offline  
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,094
Re: 147 Engine help!!!

Quote:
Originally Posted by Dai Alfa View Post
Did your undertray fall off? No sign of it in the picture.
1.6 didn't come with one ... to save money I guess!
gazza82 is offline  
(Post Link) post #12 of 12 Old 19-12-07 Thread Starter
Status: -
AO Member
 
ktulu123's Avatar
 
Join Date: Mar 2007
Location: Ireland
County: Wicklow
Posts: 70
Re: 147 Engine help!!!

Quote:
Originally Posted by RicksAlfas View Post
The first pic looks like a really sad face....
haha, good spot!!
ktulu123 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , engine

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome