Cam belt problem!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 15-12-07 Thread Starter
Status: -
 
Join Date: Dec 2007
Posts: 6
Help Cam belt problem!!

Hey all,

Some help needed here please!!

I have had what you might call a ticking noise coming from around the cam belt cover area of the engine for about the last 6-8 months, after looking around on various sites, it would appear that this is an indidcation of the cam belt tensioner / variator wearing.
Anyways, whilst driving the other night, something happened, i thought at first the cam belt had snapped, but after looking, that hasn't happened, the belt is still on all the pulleys, but loose as if it has lost tension, which leads me to believe that the tensioner has indeed failed, i was only doing about 25-30mph tops when it happened and stopped the car about 100 yards later.
Anyone had this happen to them?
I dont know what sort of damage has been done to the engine, i'm just dreading how much it's going to cost to repair!!
arsenalfan is offline  
Sponsored Links
Advertisement
 
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Cam belt problem!!

Depends if the valve timing was upset, and the valve heads clobbered the pistons. You maybe lucky, but if it stopped running suddenly, I doubt it.:
zulu ferret is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Cam belt problem!!

best to get it looked at asap...i'll be keeping my fingers crossed for you...

all the best

mike
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
belt , cam , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome