ticking noise from top end of engine - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 28-11-07 Thread Starter
Status: -
 
Join Date: Nov 2007
Posts: 36
Hmmm ticking noise from top end of engine

hi all

noticed last night after getting home from work a ticking noise from the top of the engine.

i can`t work out what the noise is and i`m abit concerned
could it be the tappets or are they self adjustable.

the thing is the belts etc have been done recently about 300 miles which included an oil change could the wrong oil have been used which is causing the excessive noise.

any help would be great because i haven`t got a clue what it could be hoping it`s nothing serious.
hightower is offline  
Sponsored Links
Advertisement
 
Status: Quieter now...
AO Member
 
RBaron's Avatar
 
Join Date: Nov 2007
Location: Lutterworth, UK
Posts: 305
Re: ticking noise from top end of engine

I presume that the engine was running, perhaps idling? Does the ticking speed vary with revs?
RBaron is offline  
(Post Link) post #3 of 7 Old 29-11-07 Thread Starter
Status: -
 
Join Date: Nov 2007
Posts: 36
Re: ticking noise from top end of engine

hi rbaron

only noticed the noise when parked on my drive but i took the car for a run late last night with the window down i can`t here the ticking only could here the tyres.

i`ll get the engine warm thhis morning and try reving to see what happens with the noise.
hightower is offline  
Status: Freezing!
AO Silver Member
 
Rockhopper's Avatar
 
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 5,266
Re: ticking noise from top end of engine

Mine does the same thing. I just ignore it.
Rockhopper is offline  
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,013
Re: ticking noise from top end of engine

I would take it back to the garage who did the belts, it may be that they have the cam timing set wrong, which is extremely likely if they have not used the correct cam locking tools.

There are also a couple of other things that can cause ticking, loose spark plugs are one, so is a damaged camshaft lobe.

It may be worth asking what oil they used, many cars nowadays need 0w-30 or 5w-30 and they may have added it thinking it will be ok, these are too thin for the TS engine though. You need a 5w-40 of 10w-40, the 40 part denoting the oils viscosity grade when hot.

Simon

Giulietta 2.0JTDm (170), BMW 335i Cabrio
symon is offline  
Status: -
AO Gold Member
 
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 6,517
Re: ticking noise from top end of engine

It could be the injectors. Nothing to worry about.
Dave Brand is online now  
(Post Link) post #7 of 7 Old 29-11-07 Thread Starter
Status: -
 
Join Date: Nov 2007
Posts: 36
Re: ticking noise from top end of engine

cheers everyone

there was no noise before the belts were done so it maybe oil or wrong timing but there`s no difference in driving.

forgot also noticed a slight squeal when the car is first started roughly near a pulley for the aux belt could this be too tight for the steering pump or something else connected to the belt or if i`ve miss placed the noise and could the timing belts to tight it goes after a few seconds.

car is going to peak alfa anyway should have gone there first due to noticing a small clatter from the engine thing that concerns me is the paperwork i`ve got says the variator was done at 63k mileage is now 68600 hopefully all gets sorted without pain.
hightower is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
end , engine , noise , ticking , top

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome