Stepper Motor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 10 Old 26-10-07 Thread Starter
Status: ready to race
AO Silver Member
 
rafe005's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,245

Member car:

159 1.9jtdm

Help Stepper Motor

I have just spoken to a garage about what I thought was a MAF problem and he suggested the stepper motor. He said it can be cleaned. Can anyone tell me the position of the stepper motor on a 146 2.0ti so that i can have a go at cleaning it
Cheers
rafe005 is offline  
Sponsored Links
Advertisement
 
Rosso145
Status: - Update
Guest
 
Posts: n/a
Re: Stepper Motor

Be very very careful!

It's located on the rear (I think, I would go and have a look, but Mrs Rosso has the car today) of the throttle body, in black, sized about 2.5 x 2 ins.

I tried this and made the tickover even more erratic.

Bite the bullet - get a new one fitted and get it plugged it to se-set the paramaters. Unfortunately, you're looking at the thick edge of £200.
 
(Post Link) post #3 of 10 Old 26-10-07 Thread Starter
Status: ready to race
AO Silver Member
 
rafe005's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,245

Member car:

159 1.9jtdm

Re: Stepper Motor

I would but it seems we are not sure if it is infact that or if it is the MAF. I had this problem before, replaced the MAF (cheap one of ebay, i know i know) but now the problem has come back so not sure if it is the stepper or just the MAF
rafe005 is offline  
Rosso145
Status: - Update
Guest
 
Posts: n/a
Re: Stepper Motor

Unplug the MAF and see what happens, however the Ebay MAF's are renowned for beeing sh1te.

I tried all sorts to crack the erratic tickover and in the finish did what I should have done right away - got in plugged in to the Alfa lap top, which diagnosed a duff stepper motor.
 
Rosso145
Status: - Update
Guest
 
Posts: n/a
Re: Stepper Motor

This is regarding the 156, but I would imagine the essentials are the same;

http://www.alfa156.net/tech/fr_index...tech/idle.html

Personally - I would put money on it being the stepper motor and fiddling often makes matters worse (as I have found out, to my expense).
 
Status: 0.9 turbo power....
AO Silver Member
 
p17sut's Avatar
 
Join Date: Nov 2004
Location: United Kingdom
County: Fife
Posts: 3,221

Member car:

500 twinair

Re: Stepper Motor

My 146ti used to rev all over the place from time to time......I just used to clean the stepper and it was fine again for another 6 months or so!
(yeah I should have just got a new one!)
You cant do it on the plastic top engines though I dont think.....or not as easily anyway!

Last edited by p17sut; 26-10-07 at 20:18.
p17sut is offline  
(Post Link) post #7 of 10 Old 26-10-07 Thread Starter
Status: ready to race
AO Silver Member
 
rafe005's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,245

Member car:

159 1.9jtdm

Re: Stepper Motor

Well i wwent down the garage earlier and as it also seems to fluctuate while driving he thinks it may be the throttle position sensor. Anyway, have now given up and when I give my car to Auto Italiana next week (for cambelt and variator change) i think I will just give them my card and tell them not to call me til its sorted
rafe005 is offline  
alfafamily
Status: - Update
Guest
 
Posts: n/a
Re: Stepper Motor

I cleaned the track and contact on the throttle position sensor on a peugeot once with a similar fault and it totally transformed the running of the car I've since seen an article on it in a jaguar magazine and they recommended it for the same fault. Well worth a try I reckon if you know what you are doing.
 
Status: V6 Inside
AO Silver Member
 
ransoman's Avatar
 
Join Date: Jan 2007
Location: United Kingdom
County: Aberdeenshire
Posts: 4,881
Re: Stepper Motor

Before you go spending mega bucks, have a look here:

https://www.alfaowner.com/Forum/just-...loverleaf.html

my recent work, did wonders on my idle for 2 months.
ransoman is offline  
(Post Link) post #10 of 10 Old 27-10-07 Thread Starter
Status: ready to race
AO Silver Member
 
rafe005's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,245

Member car:

159 1.9jtdm

Re: Stepper Motor

I have cleaned the maf as suggested, but absolutely no change. I'll clean the trottle body tomorrow and see if that does anything. Cheers for the advice
rafe005 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
motor , stepper

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome