The speedo stopped, window motors went funny and then the engine died! Help??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 25-10-07 Thread Starter
Status: -
 
Join Date: Oct 2007
Posts: 8
The speedo stopped, window motors went funny and then the engine died! Help???

Well, I've loved Alfa's since my Dad got one when I was a kid. So, time to buy a proper car... my choice? The stunning Alfa 156. Originally I wanted a 2.0 JTS but couldn't find one within 80 miles so settled on the 2.0 TS. I've had it a couple of weeks, other than a missing jubilee clip on the air intake which was easily fixed it's been great; a hell of a lot more fun to drive than anything else I've owned.

I don't even hate the fact that it's stopped working - just find myself feeling upset that I can't drive it!

Any way, the problem.

Yesterday I was driving along and the speedo just seemed to die, I couldn't bring myself to believe it when it said I was doing 0mph. So my mate checked it (hey, I'm a noob) and thought it was probably a connection. So, this morning I set off for work and the windows aren't working properly; they go up and down but the motors sound strained.
Decide to leave work thinking tomorrow is a good day to take it to the shop, it turns over, drives 10 yards then almost all of the warning lights come on, the revs start to drop and it cuts out. Tried to turn it over, nothing other than an ever so slight click in the background. None of the noises you get normally with a dead battery or anything - no noise other than this slight click.

Any ideas???

Cheers
valashua is offline  
Sponsored Links
Advertisement
 
Rayq81
Status: - Update
Guest
 
Posts: n/a
Re: The speedo stopped, window motors went funny and then the engine died! Help???

Check the Battery then the alternator
 
Rayq81
Status: - Update
Guest
 
Posts: n/a
Re: The speedo stopped, window motors went funny and then the engine died! Help???

and welcome to AO
 
(Post Link) post #4 of 7 Old 25-10-07 Thread Starter
Status: -
 
Join Date: Oct 2007
Posts: 8
Re: The speedo stopped, window motors went funny and then the engine died! Help???

Ta muchly, I'll get that checked. It was the lack of anything when trying to turn it over that freaked me out!
Cheers
valashua is offline  
Status: -
 
Join Date: Sep 2007
Posts: 13
Re: The speedo stopped, window motors went funny and then the engine died! Help???

Also be inclined to check the battery to body earth. As a loose or bad earth can have untold knock on effects in just about every system of the car.
dan0h is offline  
(Post Link) post #6 of 7 Old 26-10-07 Thread Starter
Status: -
 
Join Date: Oct 2007
Posts: 8
Re: The speedo stopped, window motors went funny and then the engine died! Help???

Hey, just to say thanks becuase the first mechanic I spoke to said I needed to replace the management system...hmmm.

Well, took your advice, gave the nice Kwik Fit man a sob story (hey, there's only two garages where I live and the otherone wouldn't listen to what I said). They wouldn't believe it was the battery but felt sorry for me and actually came to me (shock) to fit a battery... imagine their shock when it all worked!

Thanks guys, saved me a fortune no doubt! Though, actually the speedo still doesn't work... that's mondays job though!

Cheers
valashua is offline  
Status: Running in
AO Silver Member
 
Ruskins's Avatar
 
Join Date: Mar 2006
Location: United Kingdom
County: Oxfordshire
Posts: 1,415
Garage
Re: The speedo stopped, window motors went funny and then the engine died! Help???

my 147 does odd things like that also and its had a new battery, try checking the big fuses that sit on top of the battery, if its the same as the 147 that way.
Ruskins is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
died , engine , funny , motors , speedo , stopped , window

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome