JTD engine problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 23-10-07 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2007
Location: Finland
County: Etela-Suomen Laani
Posts: 65
Garage
Help JTD engine problem

Hi everyone,

Newbie here and immediately have a question for you guys. My 166 JTD suffered a breakdown on the motorway some six weeks ago. Now my mechanics from both my regular workshop and the Bosch workshop claims that my car suffers from valve problems due to oil & ash residue travelling from the intake manifold into the engine leading to internal damage. Is this possible? The story is a sad one, they have had me to buy a new ECU amongst other things when they couldn't figure out what the problem was and now after six weeks they claim that this is the problem. Anyone who has had this problem with JTD engines?

Thankful for opinions on this matter as I'm a bit suspicious after all this trouble.

//getvonen
getvonen is offline  
Sponsored Links
Advertisement
 
Status: Back to Alfa
AO Silver Member
 
Dougie166's Avatar
 
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,150

Member car:

Giulietta QV

Re: JTD engine problem

Probably better asking in the 156 technical area - Not many 166 with JTD engine on here, was never a UK option on the 166 (Petrol models only).

Good luck
Dougie166 is offline  
(Post Link) post #3 of 3 Old 23-10-07 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2007
Location: Finland
County: Etela-Suomen Laani
Posts: 65
Garage
Re: JTD engine problem

Good idea, thx.

//getvonen
getvonen is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , jtd , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome