Spider Engine stalling. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 10 Old 19-10-07 Thread Starter
GFK
Status: -
AO Member
 
Join Date: Feb 2007
Location: United Kingdom
County: Berkshire
Posts: 844
Spider Engine stalling.

Just out of the blue, after behaving impeccably, the Spider engine started stalling. As soon as the pressure is taken off the accelerator, the engine stops. Starts back again immediately and then stops when accelerator not pressed. Any ideas?
GFK is offline  
Sponsored Links
Advertisement
 
Status: -
 
Join Date: Jun 2007
Posts: 65
Re: Spider Engine stalling.

Idle control valve. Remove, clean, clean again, replace, remove, clean some more, replace.

Maybe do the old ecu reset thing afterwards too.

Oh, and clean the butterfly valve too, that'll help (maybe).
brant is offline  
Status: -
AO Silver Member
 
DevonDan's Avatar
 
Join Date: May 2007
Location: Exeter
Posts: 1,532
Re: Spider Engine stalling.

oh and the MAF while your at it! are any engine lights on?

dan
DevonDan is offline  
Status: -
AO Member
 
Join Date: Sep 2006
Posts: 62

Member car:

GTV novola

Re: Spider Engine stalling.

I had problems with over revving. I cleaned butterfly valve and it's surroundings with clean cotton clothe and there is much improvemend, although I think old idle control motor is dying on me, maybe even MAF.

BTW I found an idle control valve cleaning tutorial with photos for 2.0 TS somewhere but forgot to bookmark it. If someone has such link in their bookmarks I would be glad if he posted it in this topic.
Alfaspider is offline  
Status: -
AO Silver Member
 
BIDET FITZAKAZI's Avatar
 
Join Date: Aug 2007
County: -
Posts: 3,332

Member car:

Gtv 2.0 ts

Re: Spider Engine stalling.

A bit of a flyer, but check the throttle cable adjustment as i had the same problem and it had worked loose causing the engine not to idle.
BIDET FITZAKAZI is offline  
(Post Link) post #6 of 10 Old 22-10-07 Thread Starter
GFK
Status: -
AO Member
 
Join Date: Feb 2007
Location: United Kingdom
County: Berkshire
Posts: 844
Re: Spider Engine stalling.

Thanks all for excellent advice. I took it to Alfaid in Maidenhead with your above recommendations. I'll keep you posted.
GFK is offline  
(Post Link) post #7 of 10 Old 22-10-07 Thread Starter
GFK
Status: -
AO Member
 
Join Date: Feb 2007
Location: United Kingdom
County: Berkshire
Posts: 844
Re: Spider Engine stalling.

It was the throttle cable. It needed cleaning and re-adjustment. Thanks all. Its my wife's car as mentioned earlier. I collected it for her, doing her a favour ofcourse , then offered to do the shopping, I am an angel, I even went and did a test drive for her to make sure everything was OK. So I took the car down to the M4, shot off at exit 7, went round the country lanes of South Bucks, back to Maidenhead, did the shop and went home. 20 miles. The queus at Sainsbury, I said, terrible. Still the car is fine. Bit low on petrol though.
GFK is offline  
Status: -
 
Join Date: Dec 2007
Posts: 5
Re: Spider Engine stalling.

Hi, I've had my Spider for just over three weeks, when i initially bought it, there was an horrendous tappet noise. However other than that the car was fine. The dealer replaced the tappet and engine now sounds sweet, now after having been driven for about 45 mins and engine is warm when i depress the clutch and take my foot off of the accelerator she stalls, but will start straight up again. My mechanic thinks this could be being caused by the replacement tappet being too big and causing the valve to stay open too long or be opening too much. Does this sound feasable........Help i love my alfa and would hate to have to give her back to the dealer
Meady is offline  
Status: -
AO Silver Member
 
DevonDan's Avatar
 
Join Date: May 2007
Location: Exeter
Posts: 1,532
Re: Spider Engine stalling.

Hmm ........ if thats the case why did he fit the wrong lifter/tappet?! Is the dealer an Alfa specialist?
DevonDan is offline  
Status: -
 
Join Date: Dec 2007
Posts: 5
Re: Spider Engine stalling.

No he 's not an Alfa specialist, more like a bit of a cheap skate, turns out he had used an after market tappet which was too big which was the source of the problem. I just about managed not to hand him back the keys and allowed him a final opportunity to correct his oversight, which he has done. A lesson learnt,l know your rights when buying a car, and don't be fobbed off by a greasy car sales man
Meady is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , spider , stalling

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome