Selespeed changes gears with engine off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 15-09-07 Thread Starter
Status: -
AO Member
 
Join Date: Sep 2005
Location: CPH - Denmark
Posts: 11
Selespeed changes gears with engine off

Hi all,

Have any of you ever experienced that the selespeed would change gears continuously just after the engine is turned off and is there a solution to the phenomenon?

Im having my car checked out at an auto electrician, but after one full day in the shop they have not been able to find out anything. They will continue the diagnostics on Tuesday.

I hope I can learn something from your experiences as the bill is rapidly building up, and so far Im still at square one

Cheers
Martin
156 Selespeed, 2000
martinjordt is offline  
Sponsored Links
Advertisement
 
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Selespeed changes gears with engine off

Complicated one that sounds.: Hope your Auto Electrician can sort it for you. Good Luck.:
zulu ferret is offline  
(Post Link) post #3 of 6 Old 25-09-07 Thread Starter
Status: -
AO Member
 
Join Date: Sep 2005
Location: CPH - Denmark
Posts: 11
Re: Selespeed changes gears with engine off

Hi again,
Just picked up my car from the auto electrician today. It took three visits and two full working days to diagnose and fix the problem but I think they nailed it finally!

Over the last year I think I have tried just about every good advice I have been able to find anywhere. I have had all connectors and ground wires checked. I have replaced the battery, the selespeed relay and even the computer in the passenger side foot well. The selespeed pump has been changed (it needed to anyway though). The selespeed has been re-calibrated countless times, but nothing worked.

The real fault: A broken mounting bolt on a potentiometer worth 2

For the first time in ages I did not have to select neutral manually before starting, I did not have to watch the gear indicator flash in 1st and 2nd, I did not have to listen to the increasingly annoying beeping and watch the flashing selespeed error indicator in 5th, and finally when I turned the engine off it did not start changing gears on its own. Yes Im a happy guy today

I dont know if this is a one in a million type of error if not perhaps my experience can spare someone else the frustrations and a substantial number of costly trips to various shops

Cheers
Martin
martinjordt is offline  
harrythesnotgobbler
Status: - Update
Guest
 
Posts: n/a
Re: Selespeed changes gears with engine off

Not one I've heard before but glad you got it sorted, its such a relief when problems like this are finished and working properly
 
Status: Powered by coal and steam
AO Gold Member
 
EVEL's Avatar
 
Join Date: Jan 2007
Location: England
County: West Midlands
Posts: 9,808

Member car:

alph a ramayo

Re: Selespeed changes gears with engine off

Glad you finally sorted it Martin , they really are good fun when they work
EVEL is offline  
860
Status: -
AO Member
 
860's Avatar
 
Join Date: Nov 2006
Location: Hong Kong
Posts: 43
Re: Selespeed changes gears with engine off

Your case became the precedent.
860 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , gears , selespeed

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome