Engine tick... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 04-09-07 Thread Starter
m0t
Status: -
AO Member
 
Join Date: Aug 2007
Location: United Kingdom
County: Kent
Posts: 526

Member car:

GTV Lusso 3.0

Engine tick...

Right I have one more problem to diagnose:

I have 2 ticks in the engine bay, one from the engine itself (which I have been told is normal injector noise, and it does sound similar to the injectors on my old car).

The second one is an irregular ticking from the belt area of the engine, and it dissapears as the revs climb. It sounds a bit like 'dunk dunk dunk der-dunk'.

I have a receipt for the fitting of a 'Cambelt Kit' 8000 miles ago so I'm assuming thats fine, plus it seems to go away when I turn the steering wheel so I am assuming its PAS related.

Any ideas?
m0t is offline  
Sponsored Links
Advertisement
 
Status: Back in V6-land!
AO Silver Member
 
Ronald's Avatar
 
Join Date: Jul 2006
Location: United Kingdom
County: Kent
Posts: 3,336

Member car:

Not an Alfa

Re: Engine tick...

Power steering pump bearings on way out?
Ronald is offline  
(Post Link) post #3 of 5 Old 16-09-07 Thread Starter
m0t
Status: -
AO Member
 
Join Date: Aug 2007
Location: United Kingdom
County: Kent
Posts: 526

Member car:

GTV Lusso 3.0

Re: Engine tick...

As I was making myself some beans on toast yesterday I heard the noise again, as I lit the gas hob.

Sounds like a sparking noise, so I have had the plugs out and they all appear fine but one of the coil packs has taken on a dull grey colour (on the contacts and on the rubber).

I have ordered a new set of plugs as a precaution as well as a replacement coil pack for the one thats gone grey. Heres hoping the noise is just that.

Its a PITA to get to those rear plugs though.
m0t is offline  
(Post Link) post #4 of 5 Old 18-09-07 Thread Starter
m0t
Status: -
AO Member
 
Join Date: Aug 2007
Location: United Kingdom
County: Kent
Posts: 526

Member car:

GTV Lusso 3.0

Re: Engine tick...

I have replaced the plugs and now the engine is much quieter, but the knocking/ticking noise is still there.

Using my hammer I can tell it gets much louder by the belts and isn't constant - I start it and get no noise then it will just start up. Its not in any particular rhythm.

I have had the belt cover off and the main belt looks fine to me, but the power steering belt looks really worn, and the pulley on the pump appears to move from side to side a little (about 3mm).

Would this small movement be causing th knocking or am I looking at a bigger problem?

m0t is offline  
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,033
Re: Engine tick...

Quote:
Originally Posted by m0t View Post
I have replaced the plugs and now the engine is much quieter, but the knocking/ticking noise is still there.

Using my hammer I can tell it gets much louder by the belts and isn't constant - I start it and get no noise then it will just start up. Its not in any particular rhythm.

I have had the belt cover off and the main belt looks fine to me, but the power steering belt looks really worn, and the pulley on the pump appears to move from side to side a little (about 3mm).

Would this small movement be causing th knocking or am I looking at a bigger problem?
I would say that this movement is causing your noise. It may be allowing the belt to knock against the cam cover.
symon is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , tick

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome