A question about 156 engine refitting, and a question about the coolant system - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 08-08-07 Thread Starter
Status: -
AO Silver Member
 
Nicky's Avatar
 
Join Date: Apr 2007
Location: United Kingdom
County: Surrey
Posts: 3,269
A question about 156 engine refitting, and a question about the coolant system

2 questions about the imminent refitting of my 156 engine -

Number 1: Bleeding the coolant - how do you bleed the coolant system on a twinspark engine? I'd assume it'd be fairly easy to get some air bubbles in it during refitting, which would need to come out before the engine is run.

Number 2: Getting the engine back in - what's the easiest way to do it? Getting it out, it was a real PITA to get it off the driveshafts. Is there an easy way to pull them outwards or something so that the engine can slot into place, sit on its mounts, and the shafts can just slot in, or does it really have to be wiggled about until it goes together?
Nicky is offline  
Sponsored Links
Advertisement
 
jug
Status: -
AO Silver Member
 
jug's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Re: A question about 156 engine refitting, and a question about the coolant system

thankfully the twinspark cooling system is self bleeding, even the heater matrix! if you check the hoses for bleed screws you'll be looking a very long time
thats very rare for an italian design of that time. just remember to top up if neccessary once the air has escaped to the expansion tank.

when removing engine, disconnect the ball joint at the bottom of the hub, you can then lever the hub to withdraw the shaft enough to get it free of the box (while making sure you dont apply too much pressure on track rod end), then you tie the shaft in place with string ready for refitting. do same on both sides.
jug is offline  
(Post Link) post #3 of 6 Old 08-08-07 Thread Starter
Status: -
AO Silver Member
 
Nicky's Avatar
 
Join Date: Apr 2007
Location: United Kingdom
County: Surrey
Posts: 3,269
Re: A question about 156 engine refitting, and a question about the coolant system

Ah good, that's one thing out of the way then - I was curious as to why I hadn't noticed any bleed points

The engine's already out as I say, but it did take a bit of wiggling to get it off the shafts. Would I need a ball joint splitter or something to do it this way then? How easy is it to get apart and to re-assemble?

Cheers
Nicky is offline  
jug
Status: -
AO Silver Member
 
jug's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Re: A question about 156 engine refitting, and a question about the coolant system

the balljoint can be a pig to seperate, you dont specifically need to go out and buy a splitter if you dont have one, a large flatblade screwdrvier or a small chisel can work just as well.
jug is offline  
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,088
Re: A question about 156 engine refitting, and a question about the coolant system

You will be better off getting a splitter ... miss with the screwdriver and it's two new lower arms when you rip the balljoints open.

And if they have been on for a while, they take some effort to remove. I did my first pair with a splitter you hit with a hammer ... I used a 4lb club one and totally destroyed the balljoint covers. Didn't matter as there were two new arms going on.
gazza82 is offline  
Status: -
AO Member
 
Join Date: Jul 2007
Location: Denmark
Posts: 19

Member car:

Alfa156

Re: A question about 156 engine refitting, and a question about the coolant system

On mine there is a bleed-point in the top-left of the radiator (depending on how you look at it(still in the top though)). It´s only a plastic screw, so use a big flathead screwdriver that fits well.
Thiele is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , coolant , engine , question , refitting , system

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome