engine management light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 25-07-07 Thread Starter
Status: -
 
Join Date: Jul 2007
Posts: 3
engine management light

hi all been having problem with my 156 the orange engine management light keeps coming on after resetting the car been in the garage half a dozen times have changed all o2 sensors lambda sensors and maf meter, still having light problems any ideas?.please helppppppppppppppp.
burn ruba is offline  
Sponsored Links
Advertisement
 
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 29,957
Re: engine management light

Which engine?
David C is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,811
Re: engine management light

Check the battery is giving 12v. Read here for more information:

https://www.alfaowner.com/Forum/alfa-...r-battery.html
Pud237 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , light , management

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome