funny tapping from the engine at 2000rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 9 Old 22-07-07 Thread Starter
Status: -
 
Join Date: Jul 2007
Posts: 26
funny tapping from the engine at 2000rpm

my alfa 156 2.0 t/spark has a strange tapping sound comming from the engine when it is warm i start the car from cold and the engine sounds sweet but as soon as it is warm the noise appears especially at 2000rpm any ideas folks also still getting the power lag k reg seat ibiza tdi should not be keeping up with me
loon4000 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Jul 2007
Location: edinburgh
Posts: 50

Member car:

polo 9n

Re: funny tapping from the engine at 2000rpm

my bet is the balance shaft belt tensioner, had loads of these at work, after fitting a brand new alfa balance shaft belt, once the car is up to temp the knocking starts, we thing at work, the belts are stretching once hot , causing the tensioner to slacken and knock off the end stops on it. after fitting another alfa belt it was the same, we replaced several tensionres and belts on one car (under warranty) but still the same. only after trying an aftermarket belt (QH) the noise went away.

remove the timing belt cover and have a look at the tensioner when its running
scotland is offline  
(Post Link) post #3 of 9 Old 22-07-07 Thread Starter
Status: -
 
Join Date: Jul 2007
Posts: 26
Re: funny tapping from the engine at 2000rpm

would this affect power
loon4000 is offline  
Status: -
AO Member
 
Join Date: Jul 2007
Location: edinburgh
Posts: 50

Member car:

polo 9n

Re: funny tapping from the engine at 2000rpm

no
scotland is offline  
Status: I wanna go back to Milano!
AO Member
 
888dee's Avatar
 
Join Date: May 2004
Location: North of Northern England
Posts: 835
Re: funny tapping from the engine at 2000rpm

scotland is right about dodgy balance belts, dayco have been putting out variable batches of balance belts for a while now, I understand it's due to a slightly wrong profile to the tooth....

have you had the belts changed recently?

anyway, if it's not the balance belt one thought would be the start of a slight big end noise, get it investigated very soon, if it is that a straightforward change of the big end shells would sort it out for not a lot of money, £100ish but left it could be a very serious amount of cash to sort it out...

or if your struggling for performance the variator could be the culprit, when were the belts changed last and was the variator changed?

888dee is offline  
Status: Ultimate Driving Machine my arse
AO Silver Member
 
Jim145's Avatar
 
Join Date: May 2005
Location: United Kingdom
County: West Yorkshire
Posts: 2,043
Re: funny tapping from the engine at 2000rpm

I suspect a faulty MAF could be the loss of power.
Jim145 is offline  
Status: -
AO Platinum Member
 
Gary Slegg's Avatar
 
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: funny tapping from the engine at 2000rpm

I'm afraid it could also be one of the main bearings being worn or piston slap
Gary Slegg is offline  
(Post Link) post #8 of 9 Old 22-07-07 Thread Starter
Status: -
 
Join Date: Jul 2007
Posts: 26
Re: funny tapping from the engine at 2000rpm

cheers i will have to check these things out only had the car 3 weeks thank god it's still under warrenty lol
loon4000 is offline  
Status: -
Newbie
 
Join Date: Feb 2011
Location: France
County: Aquitaine
Posts: 7
Quote:
Originally Posted by scotland View Post
my bet is the balance shaft belt tensioner, had loads of these at work, after fitting a brand new alfa balance shaft belt, once the car is up to temp the knocking starts, we thing at work, the belts are stretching once hot , causing the tensioner to slacken and knock off the end stops on it. after fitting another alfa belt it was the same, we replaced several tensionres and belts on one car (under warranty) but still the same. only after trying an aftermarket belt (QH) the noise went away.

remove the timing belt cover and have a look at the tensioner when its running
after changing all belts, tensioners, idlers, cam oil seals, variator, I have the same problem : the balance belt tensioner indicator is moving a lot and knocking off the end stops on it.
apachelry is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
2000rpm , engine , funny , tapping

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome