Engine noises - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 17-07-07 Thread Starter
Status: -
Newbie
 
Join Date: Jul 2007
Posts: 4

Member car:

156 sw

Engine noises

Read a lot in here about variator noises, But has anyone experianced any hydrolic lifter problems IE: Total or partial failure, Which also can sound like the variator?
Reason for asking is that most of the threads in here on variator noises are all from cold start & tend to dissapear after a certain amount of time, but with my 2.0ltr jts it seems fine when cold but dont half sound tappety/Rattley when really warm,
Would appreciate any help
HalfLife is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Jul 2007
Location: Denmark
Posts: 19

Member car:

Alfa156

Re: Engine noises

I have just rebuilt my cylinderhead due to a cambelt failure
Before this happened I had a very distinct diesel sound / tapping noise. What I discovered during the rebuild was that all the lifters were stuck. I accidently "shot" one apart with air pressure...that´s when I discovered the internals of a lifter. One small piston with a no return valve inside a bigger piston inside the lifter body. After that I took all of them apart and got them "springy" again.
When I started up after finishing, it sounded like an engine straight of the factory
Only problem now is that I get quite a big amount of smoke after standstill. I think some of the sealings on top of the valves are shot. I might have to redo the whole thing
Thiele is offline  
jug
Status: -
AO Silver Member
 
jug's Avatar
 
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Re: Engine noises

sounds like a noisey tappet, possibly because it is starved of oil. check your oil level. if its ok, add a can of engine flush to the engine oil and let it idle till it gets hot, if it gets noticably quieter you know oil starvation is the problem and you need to flush the oilways. dont forget, dont drive around with the engine flush still in.

other possibilties are a dead tappet, or a worn camshaft lobe causing the valve clearance to be significantly out (compression test could confirm this).
jug is offline  
(Post Link) post #4 of 4 Old 18-07-07 Thread Starter
Status: -
Newbie
 
Join Date: Jul 2007
Posts: 4

Member car:

156 sw

Re: Engine noises

Thanks
Will be Changing the timing belt soon, so i'll be finding out one way or another
HalfLife is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , noises

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.4 jtd flatspot bruce Alfa 147, 156 & GT 31 11-05-08 09:08
Newbie Alfa Owner, worrying Engine noises! dave_v2 Alfa 147, 156 & GT 12 22-07-06 12:35
Newbie Alfa Owner, worrying Engine noises! dave_v2 Introduce Yourself 3 19-07-06 13:53
More Weird engine noises ramzey Alfa 147, 156 & GT 1 16-07-06 10:22

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome