Engine cutting out in bursts..... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 14 Old 12-07-07 Thread Starter
Status: -
 
Join Date: Apr 2007
Posts: 18
Not Happy Engine cutting out in bursts.....

Ok here's a one for you experts.....

My 2001 2.0 TS GTV has started cutting out in short bursts when I'm driving normally. The engine electrics seem to have a heart attack then burst back into life after a second. There is a red light (like a rectangle at 45 degrees with squirts comming out of the bottom) which comes on then goes out after a few seconds.

I thought that it might be a relay problem as there are three under the o/s plastic cover over the wheelarch. If the middle one works loose then the car won't fire up (had this problem in the past) but it does not seem to make any difference if I give this a squeeze (unless of course it is now so loose that i should be replacing it).

Any thoughts before I book it in to the garage yet again.
lovehatelovegtv is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
t35tvk's Avatar
 
Join Date: May 2007
Location: Alloa
Posts: 320

Member car:

That↑↑↑

Re: Engine cutting out in bursts.....

Hi. The light you refer to is the 'injection failure warning light' and I know that the injection system relay is under the offside panel you refer too so, I think you might just have diagnosed your problem. I would replace the relay and see how you get on before putting it into the garage.

Good luck
t35tvk is offline  
(Post Link) post #3 of 14 Old 12-07-07 Thread Starter
Status: -
 
Join Date: Apr 2007
Posts: 18
Re: Engine cutting out in bursts.....

Do you think that a dodgy relay would give an intermittent fault?

A bit more info having been trying to thrash the problem away tonight.

The problem does not seem to be there when the engine is cold but once up to operating temp it comes and goes (bit like kangaroo petrol feeling) I sat in a layby and held the revs at 4000 for a few mins. The problem came and went, again no real pattern other than holding at high(ish) revs seem to make it happen. The car will tick over without missing a beat all day. Drove home from work and if kept below 3000 revs will be okay (ish) but once above this level the problem returns.

Anyway, I've decided to take your advice t35tvk and order a new relay as they are only £6.00 each. They are on 48 h delivery so once I get it I'll let you know how I get on.

Any more suggestions anyone???
lovehatelovegtv is offline  
happy man
Status: - Update
Guest
 
Posts: n/a
Re: Engine cutting out in bursts.....

t35 is right that's injection failure light but if you get Kangaroo over 3k revs it could also be the Variator is on the way out.

When was the variator and belts last replaced ?

Do you get a bit of rattle / Deisel sound on start up if you do it's more likely to be the variator.

If it feels like you're hitting the rev limiter at 3k revs it's the variator
That's not terminal but it does spoil your fun
 
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,073
Re: Engine cutting out in bursts.....

I dunno if the TDC sensor is about to fail.. My old bus did that for a few days before it completely died.

Ralf S.
Ralf S. is offline  
(Post Link) post #6 of 14 Old 13-07-07 Thread Starter
Status: -
 
Join Date: Apr 2007
Posts: 18
Re: Engine cutting out in bursts.....

Having just spent about £2500 on having the engine rebuilt when the timing belt snapped 2 months ago I hope that it's not a variator type issue. I had assumed that these would have been replaced at the time.

Is this something that is expensive to sort out.
Same question in respect of TDC sensor....
lovehatelovegtv is offline  
Status: -
AO Member
 
Join Date: Dec 2006
Posts: 116

Member car:

Alfa Romeo GTV

Re: Engine cutting out in bursts.....

my injector light kept coming on intermittanly recently. turned out to be one of the relays next to the fuse panel - middle one of 3 i think. took it out, shook it, blew on it and its been finr ever since.

Mechanics is easy!!
wossobama is offline  
(Post Link) post #8 of 14 Old 18-07-07 Thread Starter
Status: -
 
Join Date: Apr 2007
Posts: 18
Re: Engine cutting out in bursts.....

Ok, I've now replaced the ingition relay but problem still persists. I've also noted that when the "cut out" occurs the warning light on the water temp gauge also comes on for a second or two..... How odd!!

Any suggestions please.
lovehatelovegtv is offline  
Status: -
 
Join Date: Jun 2007
Posts: 3
Re: Engine cutting out in bursts.....

I think it could be your spark leads.Does the car have a hik cup?Or miss fire?
rakeem is offline  
(Post Link) post #10 of 14 Old 20-07-07 Thread Starter
Status: -
 
Join Date: Apr 2007
Posts: 18
Re: Engine cutting out in bursts.....

FIXED!!! ... Update.
Took car to auto electrician who confirmed that the holder for the relays was a bit dodgy and the terminals needed a good clean and tightening up. 1/2 hour labour £15. New relay £6.20. Working GTV...... priceless.
lovehatelovegtv is offline  
Status: -
AO Platinum Member
 
Gary Slegg's Avatar
 
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: Engine cutting out in bursts.....

That's good news
Gary Slegg is offline  
Status: V8, baby. V8
AO Silver Member
 
Commanderfish's Avatar
 
Join Date: Apr 2007
Location: SW London
Posts: 5,559
Re: Engine cutting out in bursts.....

hey love hate love, are you an Alice in Chains fan?
Commanderfish is offline  
Status: -
AO Member
 
s2artfraser's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: South Lanarkshire
Posts: 17
Re: Engine cutting out in bursts.....

sounds like a bad earth strap
s2artfraser is offline  
Status: -
AO Member
 
s2artfraser's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: South Lanarkshire
Posts: 17
Re: Engine cutting out in bursts.....

sorry my appologies i had this before its the lambda sensor it stalls engine in various revs.
s2artfraser is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
bursts , cutting , engine

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 4 Weeks Ago 13:36
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
alfa 156 tuning belfast bob Tuning & Upgrades 29 25-06-08 20:35
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome