Wierd Engine Noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 28-06-07 Thread Starter
Status: -
 
Join Date: Feb 2007
Posts: 63
Idea Wierd Engine Noise

hello there my 156 1999 2.0 TS engine has been making a weird noise when accelerating,it only happens for a few seconds then stops,it sounds like a vibrating metalic noise,it also happens when engine breaking,it mostly happens in lower gears, can anyone tell me any info on this problem
cheers
Jay156 is offline  
Sponsored Links
Advertisement
 
Status: -
 
Join Date: Sep 2005
Posts: 7,679
Re: Wierd Engine Noise

Quote:
Originally Posted by Jay156 View Post
hello there my 156 1999 2.0 TS engine has been making a weird noise when accelerating,it only happens for a few seconds then stops,it sounds like a vibrating metalic noise,it also happens when engine breaking,it mostly happens in lower gears, can anyone tell me any info on this problem
cheers
Oh Dear, exactly same as mine did. check out my post car woes for what may be the problem.


Chris
chrisd_b is offline  
Status: -
 
Join Date: Sep 2005
Posts: 7,679
Re: Wierd Engine Noise

Here we go.....

Hope you don't have the same end result....


https://www.alfaowner.com/Forum/alfa-...-car-woes.html


Chris
chrisd_b is offline  
Status: Under the bonnet......again
AO Member
 
Alfaman156TS's Avatar
 
Join Date: Jun 2007
Location: Glasgow
Posts: 27

Member car:

147 Ti

Re: Wierd Engine Noise

Jay156,

I have exactly the same noise on my 1999 156 Selespeed, sounds a bit like a bunch of keys jangling or similar? I haven't managed to track it down yet, but I think it might be a heatshield rattling. If I track it down, I'll let you know!
Cheers
Alfaman156TS is offline  
(Post Link) post #5 of 7 Old 28-06-07 Thread Starter
Status: -
 
Join Date: Feb 2007
Posts: 63
Re: Wierd Engine Noise

i hope it aint somthing serious,
it has been happing for months now,no engine managment light has came on and the car idles and runs ok,there is a small amount of gunk under the oil cap tho,that might be part of the problem.
Jay156 is offline  
Status: -
 
Join Date: Sep 2005
Posts: 7,679
Re: Wierd Engine Noise

Sounds like it could be the heat shield then...if its been going on for a while.


Chris
chrisd_b is offline  
(Post Link) post #7 of 7 Old 28-06-07 Thread Starter
Status: -
 
Join Date: Feb 2007
Posts: 63
Lick Re: Wierd Engine Noise

I hope thats the case
Thanks for your replys
Jay156 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , noise , wierd

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Noise at between 2.5K and 3K revs? Sesonic Alfa 147, 156 & GT 18 20-04-10 22:48
2.4 jtd flatspot bruce Alfa 147, 156 & GT 31 11-05-08 09:08
Strange Engine Noise? top_man_eldo Engines (TS, JTS, JTD & V6) 6 28-12-06 08:33
1.6ts engine noise cappo Alfa 147, 156 & GT 11 06-10-06 14:53
Metal engine noise + Citroen DC2 noise at 147 start up solpap Alfa 147, 156 & GT 5 03-05-06 13:52

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome