Broken piece of engine?! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 8 Old 09-06-07 Thread Starter
Status: -
 
Join Date: Mar 2006
Posts: 32
Broken piece of engine?!

My engine's been making a rattling noise so I decided to investigate.

I removed the plastic engine cover, and found underneath 4 squareish boxes with cable going into them, like this:



Problem is, the 3rd one along seems to have totally sheered off.



What are they, is it something I can replace myself, and what are the consequences of having a broken one?!?!
Attached Images
File Type: jpg image-upload-78-744427.jpg (43.9 KB, 58 views)
File Type: jpg image-upload-89-753769.jpg (43.1 KB, 50 views)
greekpete is offline  
Sponsored Links
Advertisement
 
Status: missing Inverurie
AO Gold Member
 
Pascs's Avatar
 
Join Date: Apr 2002
Location: Qatar
County: Aberdeenshire
Posts: 8,063

Member car:

Zender 156 V6

Re: Broken piece of engine?!

Those are the individual power packs (coil packs) for the spark plugs - if one is broken then are all 4 cylinders firing?

I have seen complete sets on ebay.....

http://i12.ebayimg.com/02/i/000/a3/51/e447_1.JPG
Pascs is offline  
Status: -
 
Join Date: Jul 2002
Posts: 115
Re: Broken piece of engine?!

Hi there,

As Pascs said its one of the coil packs broken.
The bit broken off is for the second spark, so only 7 plugs are firing.
The other spark will more than likely be shorting to earth on the engine, best to get it sorted right away.

The best thing for now would to be wrapping the broken coil pack with electical instulating tape to help stop it shorting.

Hope this helps
Nobby is offline  
(Post Link) post #4 of 8 Old 09-06-07 Thread Starter
Status: -
 
Join Date: Mar 2006
Posts: 32
Re: Broken piece of engine?!

Ok, so not a tricky fix if I can get a replacement coil pack?

What are the effects of only having 7 plugs firing? I've probably been driving around like this for months since the last time reg vardy's messed around under there
greekpete is offline  
Status: -
 
Join Date: Jul 2002
Posts: 115
Re: Broken piece of engine?!

Na, not a tricky fix, just buy one coil pack.

There won't be to much of an effect as most cars only have 4 plugs, and the bit that is broken on yours is for the secondary spark and not the main.

Thats p++s poor of them to leave it like that, I would go back and have a moan, its worth a try, if only if they give you a discount on the part.
Nobby is offline  
Status: age is only a number ;-)
AO Gold Member
 
rgwm's Avatar
 
Join Date: Aug 2004
Location: Burnley-ish
County: Lancashire
Posts: 9,487
Re: Broken piece of engine?!

I've a few spare coil packs, if you need one give me a call on 07976 384980.....

Richard
rgwm is offline  
(Post Link) post #7 of 8 Old 20-06-07 Thread Starter
Status: -
 
Join Date: Mar 2006
Posts: 32
Re: Broken piece of engine?!

I've now got my new coil pack, but I think I'm missing something trying to fit it.
There's the 2 bolts that hold each one in place, so I undid those thinking it might just lift out - of course it doesnt.
So I then undid the 5 bolts which secure the plate with all the coil packs on, thinking they would then all lift out - it wouldnt budge.
What do you have to do to remove the coil pack?
greekpete is offline  
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,094
Re: Broken piece of engine?!

Take the whole plate out with all the packs attached. There should be some hex bolts that hold the plate on ... one with a brown earth wire. (From your pictures there are two in the centre and one at the top edge at each end ... so 4?)

It takes a bit of pulling as you are disconnecting the packs from the plugs and they have long rubber covers which grip ....

You may also need to gently pull the 2nd plug lead off as you go as these aren't attached to the late.

Swap the busted pack(s). The coil packs are held in place by the round-headed hex bolts.

And put it all back in one piece. Don't forget that earth wire!

cheers, Gary

HIS: ex-1998 156 2.0 TSpark with Sport Pack 2, sunroof and hi-level spoiler in Alfa Rosso. V6 intake mod, clear side repeaters and Zeatek undertray. 10th Sep 1998 to 12th Jan 2017

HERS: 2009 MiTo 1.4 95bhp Turismo arrived 21st November in Techno Grey with colour-coded headlight surrounds.

My Alfa156 Web Site - how-to's, piccies, links, useful stuff, etc.

Last edited by gazza82; 20-06-07 at 14:42.
gazza82 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
broken , engine , piece

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
alfa 156 tuning belfast bob Tuning & Upgrades 29 25-06-08 20:35
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50
broken engine Arhont_selespeed Engines (TS, JTS, JTD & V6) 16 02-04-07 06:38

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome