Gt needs help 😞 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 16-12-13 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: West Yorkshire
Posts: 18

Member car:

Alfa gt

Gt needs help 😞

Hi all,

Just recently my GT 2.0l jts (54) has developed a stutter when I want to accelerate. I've had a google about and it's pointing towards MAF,EGR and possibly air inlet split pipe?? I'm not very hands on but don't want plough a load of money into chasing it around... Has anyone had the same problem before??

Many thanks

Deano
Deanogt is offline  
Sponsored Links
Advertisement
 
Status: now I'm not sure
AO Member
 
whatmoretyres's Avatar
 
Join Date: Mar 2007
Location: United Kingdom
County: Bucks
Posts: 989

Member car:

GT DIEsel

Well, knowing that engine's issue... It could be the injectors failing. Best bet is get it to one of the specialists for a check
whatmoretyres is offline  
Status: -
AO Member
 
Join Date: Oct 2013
Location: New Zealand
County: Waikato
Posts: 14
Possibly a coil? Pull the codes before diving in
brownbox is offline  
Status: -
AO Member
 
hasmac's Avatar
 
Join Date: Oct 2004
Location: United Kingdom
County: Hampshire
Posts: 126
Yes it could be inlet pipe split, mine once split at the concertina section, taped it up with gaffer tape and it was OK, got the pipe replaced at the next service. The symptom was a stutter pulling away, then as it got worse it turned in to a judder. Open the bonnet, it's the big rubber pipe running from air box at front to throttle at back, give it a squeeze while looking closely for splits.

It could be an air leak somewhere else, like a crankcase ventilation pipe or a loose jubilee clip, or the MAF, anything that gives an air\fuel ratio imbalance, the system is very sensitive to incorrect air\fuel mixtures. JTS doesn't have EGR, that's just for JTD's.

Defenitley worth a poke around first see if it's something obvious.
hasmac is offline  
Durty dog
Status: - Update
Guest
 
Posts: n/a
I to would just check for obvious and cheap solutions first, check all inlet hoses, air filter, loose electrical connections. They will cost you at the most a couple of hours under the bonnet.
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome