Ecu help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 14-11-13 Thread Starter
Status: -
AO Member
 
jeromedeakin's Avatar
 
Join Date: Sep 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 19

Member car:

147 jtd 16v mjet

Ecu help

Hi everyone need some urgent advice


My 147 jtd turbo packed up about 8 months ago and it has been sat on my drive since just got round to changing the turbo and thought I would try to fire it up before hand just to make sure it still started. My old battery was dead so tried using my battery of my astra petrol, there was no warning lights in the dash or any power at all not even for the lights in the cabin does this mean the ecu has lost all the codes or even worse the ecu is screwed. I only have 1 key which is not the master and I'm not sure what to do next any advice would be appreciated cos I don't want to scrap it n live with a euro box

Cheers
jeromedeakin is offline  
Sponsored Links
Advertisement
 
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,094
Sounds more like battery hasn't connected properly. Lights on dash shouldn't rely on ecu.
gazza82 is online now  
Status: -
Newbie
 
selespeed155's Avatar
 
Join Date: Jun 2012
Location: United Kingdom
County: Leicestershire
Posts: 6

Member car:

selespeed 155 ,

Main fuse
selespeed155 is offline  
Status: back in an Alfa :)
AO Member
 
Tanis8472's Avatar
 
Join Date: Dec 2006
Location: United Kingdom
County: Lincolnshire
Posts: 791
Are the battery posts correct as some have + and - opposite to others
Tanis8472 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
ecu

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome