MAF sensor replaced - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 14-01-13 Thread Starter
Status: -
AO Member
 
OLLY8080's Avatar
 
Join Date: Jan 2009
Location: United Kingdom
County: Lancashire
Posts: 100
MAF sensor replaced

Hi Guys

Just had a new MAF fitted but only done about 2 miles and its running brilliant once more but is still struggling at 5000 rpm ( brick wall ) will the ecu pick up on this and change its settings ?

if so how many miles
OLLY8080 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 29,958
Is it a proper genuine Bosch MAF?
and
Is it the correct one for your engine?
David C is offline  
(Post Link) post #3 of 3 Old 16-01-13 Thread Starter
Status: -
AO Member
 
OLLY8080's Avatar
 
Join Date: Jan 2009
Location: United Kingdom
County: Lancashire
Posts: 100
All done car running like new and up by the 50 bhp it lost 0 to 60 7 seconds and got 148 out of it the other night
OLLY8080 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
maf , replaced , sensor

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome