JTS engine sounding unusually "raspy" - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 10-11-12 Thread Starter
Status: -
Awaiting Email Conf
 
Join Date: Jan 2012
Location: United Kingdom
County: South Yorkshire
Posts: 253
JTS engine sounding unusually "raspy"

Hi all,

I have the 2.0JTS engine in my GT, and i've noticed that since the weather has turned cold, my car has started to sound significantly more "raspy", quite like a cheap exhaust would sound... i'd like to say it sounds nice but it doesn't! Is this something anyone has noted in cold weather? The "noise" seems much more apparent when the engine is cold, but isn't completely gone after the engine has warmed up.

Is it possible that I have a blowing exhaust? And the weather is a mere coincidence? Is there any easy way to tell? I bought the car during the cold weather in February, so wasn't really in a position to notice anything unusual about the sound back then, but now it sounds really apparent!

Cheers
B
Ballamness is offline  
Sponsored Links
Advertisement
 
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,113
Garage
The best option would be to get it checked i can't get under the car yourself
Joss is offline  
(Post Link) post #3 of 4 Old 11-11-12 Thread Starter
Status: -
Awaiting Email Conf
 
Join Date: Jan 2012
Location: United Kingdom
County: South Yorkshire
Posts: 253
I have ramps but what would I be looking for? Would it be glaringly obvious?
Ballamness is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,113
Garage
check round all joints for blowing with fingers. don't touch it mind
Joss is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , jts , raspy , sounding , unusually

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome