Glowplug question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 19-09-12 Thread Starter
Status: GOT CAMS?
AO Silver Member
 
BenzinaBrera's Avatar
 
Join Date: Aug 2010
Location: South Africa
County: Gauteng
Posts: 2,985

Member car:

Brera 3.6

Glowplug question

Hi, guys, my glowplug resistance tests fine but i get a P0683 - Glow plug heater module error, is the module a seperate thing that i need to replace?
BenzinaBrera is offline  
Sponsored Links
Advertisement
 
Status: Back to chilling out
AO Member
 
TI-ger boz's Avatar
 
Join Date: Oct 2008
Location: United Kingdom
County: North Yorkshire
Posts: 312

Member car:

Giulietta 1.4MA

It's a black cube shaped box about 2.5 inch per side just to the side of the fuel filter on the bulkhead. Or at least it was on my 147.
TI-ger boz is offline  
(Post Link) post #3 of 4 Old 19-09-12 Thread Starter
Status: GOT CAMS?
AO Silver Member
 
BenzinaBrera's Avatar
 
Join Date: Aug 2010
Location: South Africa
County: Gauteng
Posts: 2,985

Member car:

Brera 3.6

Thanks i found it :-), i wonder if the module could be faulty, is it possible that it outputs too little voltage with all 4 glows connected? I noticed it doesnt get as hot with all 4 connected
BenzinaBrera is offline  
Status: Back to chilling out
AO Member
 
TI-ger boz's Avatar
 
Join Date: Oct 2008
Location: United Kingdom
County: North Yorkshire
Posts: 312

Member car:

Giulietta 1.4MA

I believe they are a fairly common problem but the output can be affected by battery condition and the electrical connections. Worth checking the battery and the voltage on the input side of the control unit before replacing.
TI-ger boz is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
glowplug , question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome