Is my ecu dying? This is a wierd one! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 21-08-12 Thread Starter
Status: BOTH Alfa drivable again!Yippee!
AO Member
 
captainboogaloo's Avatar
 
Join Date: Jul 2011
Location: United Kingdom
County: Somerset
Posts: 401

Member car:

156 2.4 jtd x2

Help Is my ecu dying? This is a wierd one!

Ok guys, I could sure use some help with this - my beloved 156 2.4 jtd Sportwagon has got a bizarre fault - the cam sensor is reading a fault, and I have the proverbial engine management light on. This is combined with a pronounced ticking noise from the injectors, the noiseiest being nearest the gearbox. Not that wierd, you are probably thinking, except that these two injectors have been replaced, along with cam belts, tensioners, the tappets have been checked and shimmed (required very small shims) and, yep, the cam sensor has been replaced. The Alfa dealer who did the work believes the fault lies with the ecu. I have a replacement arriving tomorrow for the ecu. I have been running a tuning box, decatted exhaust and auto delta air filter, and an allard motorsport egr valve delete kit, but if the other ecu doesn't solve this I will definitely be at my wits end. Which is a short trip, I'll be honest...! Has anyone any suggestions about where the fault lies? I have that desperate feeling coming on....
captainboogaloo is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 3 Old 22-08-12 Thread Starter
Status: BOTH Alfa drivable again!Yippee!
AO Member
 
captainboogaloo's Avatar
 
Join Date: Jul 2011
Location: United Kingdom
County: Somerset
Posts: 401

Member car:

156 2.4 jtd x2

What, really, no one has had an issue with their Alfa 156 ecu like this? Maybe someone could advise me if I can swap my new ecu for the old one, and still start the vehicle. The Alfa dealer has kindly agreed to recode the new one for free, but I would love to know if this will solve the lack of signal from the cam sensor. The dealer has checked the integrity and conductivity of the loom back to the ecu, in case anyone thinks of that.:Just to clarify, not too concerned about locking, alarms,etc as I guess the recode will take of those aspects, just wether or not I might expect my black beauty to start. Please god, I be running out of chickens to sacrifice...! Or to misquote Blazing Saddles, am I just jer&ing off!!!
captainboogaloo is offline  
(Post Link) post #3 of 3 Old 22-08-12 Thread Starter
Status: BOTH Alfa drivable again!Yippee!
AO Member
 
captainboogaloo's Avatar
 
Join Date: Jul 2011
Location: United Kingdom
County: Somerset
Posts: 401

Member car:

156 2.4 jtd x2

Well, the good news just keeps coming...of our two 'wagons, would anyone like to guess which one is missing the code card? Yep, that's right, the one that really needs it. My local dealer, who I 'spouse should remain anonymous , (but Longstones of Cannington would be pretty close!!) have a contact who can supply it at a price. So that's another £50 plus the vodka and tonic up the kazzoo! I love our Alfas and would no more swap them for another make than slam my gentlemans vegetables in a draw, but sweet jesus h Christ-on-a-bike!, sometimes the urge to load the shotgun and despatch her in a blaze of glory is almost overwhelming...! But then I remember the sweet feeling of leaving certain er, German vehicles behind on the M3 out of the 50 mph speed restriction, and the perfect weight of the steering through the corners and curves on the A303 and ... I could go on and on, but I guess I'm preaching to the choir. The miles bring the smiles...
captainboogaloo is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
dying , ecu , wierd

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squadra chip jason77 Alfa 155 30 23-01-02 15:49

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome