1.9 jtd 16v mjet 140 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 1 Old 01-08-12 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2012
Location: United Kingdom
County: Leicestershire
Posts: 8
1.9 jtd 16v mjet 140

Hi can anyone help ? My jtd 16v mjet (140) runs great turbo kicks in around 1500 - 2000 it sounds great no nasty noises and it fires the car along. The problem is when you go over 80 it seems to cut the turbo out then i am struggling to get up to speed once you stop its ok again it seems to work fine around town. Car has done 86.000 serviced all its life. Any info would be a god send got a few more questions if i get a responce
stevejtdworks is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
140 , 16v , jtd , mjet

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bleedin MAF CrispDust Alfa GTV & 916 Spider 28 01-06-10 19:47
Diagnostic software freeware? 156head Alfa 147, 156 & GT 27 18-03-10 14:24
Useful MAF info Rollcage Alfa 164 & 166 23 07-03-09 07:41
Idling at 900rpm- is it normal? for 156 1.9 JTD 16v MJET stealth117 Alfa 147, 156 & GT 19 06-10-08 11:01
Alfa 156 1.9 JTD 16V MJet 140HP - Performance Problem pcamara Alfa 147, 156 & GT 6 25-11-07 21:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome