156 2.5v6 flat midrange - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 1 Old 18-07-12 Thread Starter
Status: -
Newbie
 
Join Date: Jul 2012
Location: United Kingdom
County: Bristol
Posts: 3

Member car:

156 2.5 v6 1998

Hmmm 156 2.5v6 flat midrange

Hi all - long time reader, first time poster. Got a long term issue with a lethargic 1998 2.5V6 which doesn't seem to fit any of the usual suspects... anyone like a puzzle?

Starts & runs fine, no misfires, revs well, no smoke etc. But very little torque - floor it and it accelerates painfully slowly through the low and midranges before picking up to a decent level higher up. I'm no boy racer, but I almost got burned a Citroen boxer VAN on a hill the other day, and the wife's Mondeo tcdi would eat it alive (quite embarrassing, especially when she also gets three times the MPG!)

Now... following a previous problem last year I reset the ECU and it absolutely flew, pulling strongly throught the range. Finally I understood what all the fuss about the alfa V6 was about!... unfortunately it only lasted 10 days before gradually reverting back to sluggish again! Since then resetting does nothing - but at least I know how it SHOULD feel, and clearly the engine is capable but held back.

Disconnecting the MAF does nothing (bizarrely the midrange is slightly better but horribly flat at top and bottom!). Also a specialist tested it and found no MAF issues and no sensor errors. He found a hole in the intake flexi but sealed it right up and only marginally better.

Finally, a curve ball - I started her up the other day, drove 5mins to get fuel. When I started up again I could tell immediately that all the horses had all sneaked back under the bonnet. Happy days... except it only lasted for two short journeys, then back to normal (fuel level normally has no effect).

Any ideas? From what I see most V6s have either low down misfires, or high revving hesitency. Mine has neither, it's just flat - shouldn't need to change down to 2nd at 40mph+ to get anywhere, surely?! When it was going well performance was almost comparable to my old Nissan 200sx, but currently it's no faster than the 1.8TS I had before this one, so I'd say it's down at least 40% in the low/midrange.

anyone heard of anything similar?
Scrumpy1977 is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , flat , midrange

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome