2.2 jts stumble after starting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 01-06-12 Thread Starter
Status: -
AO Member
 
Mozella's Avatar
 
Join Date: Oct 2011
Location: Italy
County: Alessandria
Posts: 204
2.2 jts stumble after starting

I have no complaints about how my Spider runs. The reported hesitation and poor throttle response associated with this engine simply doesn't exist on my car. I know it has not been remapped, yet it runs perfectly with one exception.

When I start the car it shakes and rumbles for a very short period of time, only around a second and a half or so. Then it idles as smooth as can be. It does this warm or cold and is not associated with "warming up". The behavior is the same each time and never lasts more than two seconds.

If this car had carburetors you would want to pump the throttle to actuate the acceleration pump(s). It acts as though it doesn't want to start, yet it never fails to do so. I'm guessing that most people wouldn't even notice, but I'm kind of sensitive to how my cars and motorcycles run, especially if they do something odd.

In short, I've never owned a well tuned and smooth running fuel injected engine which acts like my Spider. Years ago my Porsche 911 with twin Weber three barrel carburetors used to cough and spit for a while, but it was pretty primitive and in a high state of tune; i.e. rough running when cold was normal.

Does anyone else with a 2.2 jts notice a second or two of shaking immediately after starting followed by perfect behavior?

I'm not so much worried as curious.
Mozella is offline  
Sponsored Links
Advertisement
 
Status: Broken again...
AO Platinum Member
 
GhostyDog's Avatar
 
Join Date: Sep 2005
Location: Right Side O The Pennines
County: West Yorkshire
Posts: 25,672
hold the start stop button longer, I find if you just give it a stab, sometimes it just turns over but doesn't start, a bit longer and it's grumbly, keep it held til it's fully started and no issue.
GhostyDog is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
jts , starting , stumble

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome