Limp Mode Cured! :) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 15-05-12 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2012
Location: United Kingdom
County: Nottinghamshire
Posts: 7

Member car:

2001,156 2.4 JTD

Limp Mode Cured! :)

Well after a few weeks of checking everything and reading up on here i concluded me vanes were sticking in the VNT.
1 can of carb cleaner sprayed into turbo inlet and it is virtually cured, another can will finish it off, well pleased cos i can use all that power now.
Gonna have to play with me mate's ST now
sickbag is offline  
Sponsored Links
Advertisement
 
Status: -
Newbie
 
Join Date: Aug 2012
Location: United Kingdom
County: Leicestershire
Posts: 8
156 1.9 jtd 16v (140) m jet

Hi can anyone help ? My jtd 16v mjet (140) runs great turbo kicks in around 1500 - 2000 it sounds great no nasty noises and it fires the car along. The problem is when you go over 80 it seems to cut the turbo out then i am struggling to get up to speed once you stop its ok again it seems to work fine around town. Car has done 86.000 serviced all its life. Any info would be a god send got a few more questions if i get a responce
stevejtdworks is offline  
Status: novice oil burner.
AO Member
 
Join Date: Dec 2008
Location: United Kingdom
County: Hampshire
Posts: 222
Hi, can you give details of the process you did and the product you used?

Cheers
Dave
Davey_saxo is offline  
(Post Link) post #4 of 4 Old 27-08-12 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2012
Location: United Kingdom
County: Nottinghamshire
Posts: 7

Member car:

2001,156 2.4 JTD

I used carb cleaner, just removed pipe to maf and with engine running sprayed direct into inlet, revs will rise and fall depending on how much you spray but i used a full can. vanes in turbo soot up causing them to stick, this does work so long as the soot build up isnt too bad. if it is then it's turbo off and stripped to be cleaned..
hope that helps.
sickbag is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
cured , limp , mode

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode: 07 Brera 2.4 oakerz Alfa 159, Brera & 946 Spider 2 18-10-11 20:29
3 days in limp mode sargent Alfa 159, Brera & 946 Spider 6 12-09-11 08:37
HELP !! My Alfa 156 Selespeed goes in and out of Limp mode Fabio911 Alfa 147, 156 & GT 5 29-08-11 18:43
Limp Mode 3 times in 8 days! Sandman_7 Alfa 159, Brera & 946 Spider 22 22-09-09 10:54
Intermittent Limp mode alfatom Alfa 147, 156 & GT 3 03-09-09 13:56

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome