Strange squeeking/ creaking noise under boost - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 1 Old 22-04-12 Thread Starter
Status: Still wrapped up in the V6...
AO Silver Member
 
James Junior's Avatar
 
Join Date: May 2009
Location: United Kingdom
County: Cheshire
Posts: 1,001
Strange squeeking/ creaking noise under boost

After I had my 2.4 Spider remapped I began noticing a strange noise when accelerating.

Kind of like a faint creaking/ squeeling sort of sound.

It kind of pulsates as you accelerate hard rather than rising in unision with the revs.

John at MVC did find the FMIC was split and we replaced this, but the strange noise persists.

I have read some threads about boost leaks and wonder if this may be what is causing it.

Has anyone experienced anything similar or got any ideas?
James Junior is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
boost , creaking , noise , squeeking or , strange

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome