Timing problem? JTDm 16v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 14-04-12 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Cheshire
Posts: 51
Timing problem? JTDm 16v

Replaced all belts and FES gave figure of Injector Timong of 0deg. Error codes 0190 & 0683 have come up and car won't start. FES today gave inj timing of 2;2deg. Does anyone know what correct figure should be? Does this mean timing belt may have slipped?
elmookie is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
JON156VELOCE's Avatar
 
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 3,119

Member car:

Giulia Veloce

If the cam belt has jumped a few teeth it shouldnt effect the injector timing, but you should get a cam position sensor fault.
JON156VELOCE is offline  
(Post Link) post #3 of 3 Old 17-04-12 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Cheshire
Posts: 51
Thanks for that. No fault showing so has put my mind at ease. I think it may be due to vacuum pipes I replaced, will be checking them this evening.
elmookie is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
16v , jtd , jtd multijet diesel , jtdm , problem , start , timing

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 4 Weeks Ago 13:36
Waterpump/belt failure on the JTD 16v & 20V engines Spider95 Alfa 147, 156 & GT 805 11-07-19 10:45
My 147 boot hatch says it's open even with new switch? Software? Alf_the_Alfa Alfa 147, 156 & GT 2 26-03-11 23:15
Bleedin MAF CrispDust Alfa GTV & 916 Spider 28 01-06-10 19:47

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome