Low revs and no power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 07-04-12 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2012
Location: United Kingdom
County: Nottinghamshire
Posts: 2

Member car:

alfa romeo gt

Low revs and no power

I put some dodgy diesel in my Alfa GT JTDM. (yes I know it was stupid!).

Initially the fuel pump was very noisy - irritatingly noisy!. Drained the tank, replaced the fuel filter added diesel treatment etc and eventually the pump quietened down.

As it is now, If I accelerate to 3000rpm the car does one of two things - it cuts out or it does nothing just stays at 3000rpm.
Also the engine manangement light is constantly on on the dash - I guess that is to be expected.

Any Ideas as to what I should do next????
sb2982 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
JON156VELOCE's Avatar
 
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 3,119

Member car:

Giulia Veloce

Hope it wasnt bleached red, I know of several people who've bought that and needed a new pump.

You need to have the fault codes read, if it is showing low fuel pressure you probably need a new pump, It might be the same as a vauxhall Z19DTH engine so a few available second hand at a lowish price

Last edited by JON156VELOCE; 10-04-12 at 16:35.
JON156VELOCE is offline  
Status: Trying to fix my 159
AO Member
 
Join Date: Feb 2010
Location: Spain
County: Valencia
Posts: 117

Member car:

Alfa 159 2.4

Put a diagnostic machine in and see the fault..
adrianuxx is offline  
(Post Link) post #4 of 5 Old 16-04-12 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2012
Location: United Kingdom
County: Nottinghamshire
Posts: 2

Member car:

alfa romeo gt

thanks chaps - had a diagnostic on it and I need a new fuel pump..... cheap diesel
sb2982 is offline  
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,091
Quote:
Originally Posted by JON156VELOCE View Post
Hope it wasnt bleached red, I know of several people who've bought that and needed a new pump.

Looks like you might know one more!
gazza82 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
low , power , revs

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome