Gooey black mess around No.1 Injector 156SW 2.4 JTDm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 27-03-12 Thread Starter
Status: -
Newbie
 
Join Date: Mar 2012
Location: United Kingdom
County: Suffolk
Posts: 7
Gooey black mess around No.1 Injector 156SW 2.4 JTDm

Hello

Hoping for a bit of help only had the car a month finally got round to looking under the bonnet and found a gooey black mess all over the No.1 injector. I have searched the forum on here and also in some fiat forums and come to the conclusion the injector is leaking and that the copper sealing washer needs replacing.
  • Is my diagnosis correct? (I have been wrong before)
  • Has anyone replaced the injector seals before? (Is it a DIY mechanic job)
  • Will I need anything special to get the injector out? (the black goo looks like it sets when the engine is cold)
  • Will I need to replace the pipe from the rail to the injector or should it be OK to reuse?
  • What is the safest/best way to depressurise the rail? (don't want to inject myself with diesel)
  • And Finally what is the torque setting for the injector retaining bolt?

Any hints tips and info gratefully received
Macca
Redstarcar is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Oct 2011
Location: United Kingdom
County: West Yorkshire
Posts: 61

Member car:

gt jtd

easy job.

did mine a few weeks ago.

disconnect battery, dont worry about pressure it willl only be pressurised when the pump is running.

unplug the electrical connector and loosen the bolts on the injector and rail, slowly work the injector out, may take a little time be gentle.

the hard bit will be getting the old washer out, a knitting needle will help.

fit new washer and tighten.

not sure of torque setting i just went steady and tightend slowly.
pushrodv8 is offline  
Status: -
AO Silver Member
 
Cream's Avatar
 
Join Date: Mar 2002
Location: wrexham
Posts: 1,580

Member car:

Brera 2.4SV

i had this, but i didnt manage to sort it out myself before another injector started leaking and it became urgent.

my local alfa mech sorted it out, however it took 5 hours to get injector 4 out, then injector 3 started leaking (becuase of the solvents used geting 4 out) another 2 hours to get injector 3 out, anther two hours for injector 2, and then the one with the black gue - injector 1 took another 5 hours !

cost was a very resonable 660 quid

they also broke two alfa injector pullers and had to use a slide hammer in the end... just my experience
Cream is offline  
(Post Link) post #4 of 5 Old 28-03-12 Thread Starter
Status: -
Newbie
 
Join Date: Mar 2012
Location: United Kingdom
County: Suffolk
Posts: 7
Not sure what to make of that, one of you makes it sound easy the other had a nightmare. I think I will give it a go myself but I was going to run the engine for a bit to get it nice and warm try and make to goo all soft, I thought it might make it easier to get the injector out. Of course I am going to clear as much of the goo away as I can before even trying to remove it.

Thanks Macca
Redstarcar is offline  
Status: -
AO Silver Member
 
Cream's Avatar
 
Join Date: Mar 2002
Location: wrexham
Posts: 1,580

Member car:

Brera 2.4SV

coke is good for disolving the gue apprently, as is diesel itself for freeing it up, but it just depends what the injector feels like i guess, the longer its been in the engine the worse stuck it could be.

my is a 54 plate mjet 1.9
Cream is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156sw , black , gooey , injector , jtdm , mess , no1

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11
It's Official !! nomad General Alfa Discussion 92 11-07-08 16:00

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome