Worn cam belt tensioners JTD Mjet 16v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 25-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

Worn cam belt tensioners JTD Mjet 16v

Hiall,

I started getting an intermittent squeeky squeel from a roller bearing somewhere on the engine. Changed the Aux belt idler and tensioner for new items, while the belt was off felt the PAS and Alternator rotations and they both felt fine with no roughness/noise at all - very smooth.

I rekon the noise is from either the cam belt idler or tensioner, anyone else had these bearing making squeely noises? the tensioner sprocket seems to rock from side to side by a few mm when I take some the of the belt tension off it slightly.

It had a new water pump when the engine was rebuilt about 5k ago. ~cant rem if the timing belt sprockets were changed..


Anyone ele had a squeeky squeely cam belt tensioner?


~Ive ordered a new kit just incase as I got to drive 160Mile to the NEC next wkend..

1.9 JTD M-Jet 16v 140ps.
Gas flowed head, Polished valves, Port matched manifolds, New Turbo.
JS-T primary Decat, MrZ full-bore Center Decat , Oil recirc tank, Big filter conversion.
stefz is offline  
Sponsored Links
Advertisement
 
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,112
Garage
Easy way to check. Flip the aux belt off and start the engine.. If the noise is there you can assume its cambelt related and fit the kit. If not then you know its aux belt related. Its much more common for these to squeak than a cambelt
Joss is offline  
(Post Link) post #3 of 4 Old 30-03-12 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

So far, New Aux tensioner + idler, New Cambelt + tensioner + idler,

still squeely.. going to try talc on the aux belt..

hope its not the alternator...
stefz is offline  
(Post Link) post #4 of 4 Old 01-04-12 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

Mixed up some slightly soapy water with talc to form an emulsion, then dripped it onto the ribbed side of the belt around the crank pulley, spun then engine and repeated a few times to make sure all the belt had a coating.

Squeek had gone, and after a 300mile round trip to the NEC, the squeek is still gone.


Sufice to say changing all the belts and pulleys/tensioners was a good things and will not need doing for ages..


Talc + Water = Winner!
stefz is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
16v , belt , cam , jtd , mjet , tensioners , worn

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Waterpump/belt failure on the JTD 16v & 20V engines Spider95 Alfa 147, 156 & GT 805 11-07-19 10:45
Bleedin MAF CrispDust Alfa GTV & 916 Spider 28 01-06-10 19:47
Well chuffed..! SpiderMJ Alfa GTV & 916 Spider 10 06-11-09 07:30

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome