147 2.0 ts cam belt change now noisey - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 14-02-12 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2011
Location: Isle of Man
County: -
Posts: 31
147 2.0 ts cam belt change now noisey

Hi Guys,

I have a concern, History: I bought my TS about 7 mths ago 59k miles now (FSH but no cam belt change) anyway, about 3 weeks ago put her in for a new cam belt, ended up changing the whole kit with tensioners etc. Anyways, since I got her back she's had a rattle when the engine's labouring ie. 3rd gear at 1000rpm bury the foot and it sounds like either a vibtating heat shield or realistically a street band banging on some tins with their drumsticks (it's also slightly there on pull away in 1st and sometimes in second at some point)

Nothing else is different although the new belts are still whining but the mechanic has said they may be too tight. Any idea on the noise? There's no idling noise so not sure if its variator.

Any ideas what to look for?
Thanks
Marco
Execousin is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
seadart's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Hampshire
Posts: 2,197
Did a specialist do the work?? If not I'd get a specialist to give it the once over.. If the belt has been installed incorrectly it will need looking at..
seadart is offline  
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
The balance belt should of been replace along with the tensioner, this might of been over tensioned and is rattling against it's stop's.
biffa is offline  
(Post Link) post #4 of 7 Old 14-02-12 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2011
Location: Isle of Man
County: -
Posts: 31
Yes, the balance belt was changed along with the bits, (the old balance belt had snapped now you mention that) could that have caused some damage? I have read that some like it better without it so hadn't considered it. Under normal operation though the engine is quieter other than this noise!
The work was done the local fiat and Alfa specialist, who has a decent reputation.
Execousin is offline  
Status: AROC 916 Registrar
AO Gold Member
 
Mitch916's Avatar
 
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,916
Take it back and show him. If he is a good indie I'm sure he will be helpful.
Mitch916 is offline  
Status: GTV for sale ...
AO Silver Member
 
Join Date: Jan 2011
Location: United Kingdom
County: Warwickshire
Posts: 1,843

Member car:

GTV 2.0

I have had a similar worrying "tittering" rattle under load only, and have all kinds of ideas what it might be... mine has dissapeared very recently after an oil change, and an exhaust part change... with suspected hole

Either belt being too tight can make the tensioners tap against their stops... But being that it was fitted by a specialist we'd hope this is not it.
Turtle4288 is offline  
(Post Link) post #7 of 7 Old 16-02-12 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2011
Location: Isle of Man
County: -
Posts: 31
Thanks guys,
I suspect that one or all the belts are too tight. just hope that nothing is damaged. I am due back to change my rocker box and he's said he'll loosen the belts, but i was worried that there might be damage.

I'll repost asa he's done. Just waiting for a new gasket.
be in touch
Execousin is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , belt , cam , change , noisey

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome