Limp clutch pedal! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 08-02-12 Thread Starter
Status: -
Newbie
 
dullard's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Greater London
Posts: 2

Member car:

GT 3.2 V6

Limp clutch pedal!

Hi
I have a GT V6 with 42k odd miles on the clock. Not a technical wizard - as you'll appreciate from what follows - but my clutch pedal has gone limp and I can't engage any gears. Before contacting garage and having to arrange a tow, any advice from AOF gurus about whether this can be easily sorted without payment pain? (I'm hoping hydraulic fluid - have checked fluid reservoir and it's only slightly down so that might be vain hope - and fearing clutch itself.)
Any advice gratefully received!
dullard is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
seadart's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Hampshire
Posts: 2,197
is the pedal in the 'down' position?? if so can you pull it back up to the 'up' position??

if it stays up and then starts working again it may just be a 'sticky' slave cylinder.. caused by old age and/or dirty hydraulic fluid in the slave cylinder.. plus low temperatures!!.. cheapest option is to bleed out the crappy dirty old fluid and see how it goes..

Last edited by seadart; 08-02-12 at 17:20.
seadart is offline  
Status: GTV for sale ...
AO Silver Member
 
Join Date: Jan 2011
Location: United Kingdom
County: Warwickshire
Posts: 1,843

Member car:

GTV 2.0

Will cost around 80 quid to fix, needs a new slave cylinder most likely. Mechanic on the move could fix it on your drive with ease
Turtle4288 is offline  
(Post Link) post #4 of 4 Old 10-02-12 Thread Starter
Status: -
Newbie
 
dullard's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Greater London
Posts: 2

Member car:

GT 3.2 V6

Seadart, Turtle - many thanks for your pointers. Pedal did come back up after a topping up of the reservoir and vigorous pumping, and I managed to get it to supplying garage (Veloces in north London) in second... (Beauty of that engine is that even steep hillstarts are a snitch in second!) They actually replaced the master and slave cylinders under warranty so all is now perfect again.
Thanks again.
dullard is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
clutch , limp , pedal

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
147 Noisy Creaky Clutch Pedal timmywimmybumkins Alfa 147, 156 & GT 30 24-12-18 15:13
Cruise control & clutch pedal retaining pin failure .... and fix Stingbrace Alfa 147, 156 & GT 44 12-09-14 16:35
Sticky clutch pedal - Where is the linkage? robobass Alfa 147, 156 & GT 10 07-06-11 20:41
Squeaky GT clutch pedal garyribble Alfa 147, 156 & GT 0 20-11-10 14:48
Clutch pedal and Gearbox issue 2.5V6 Alfa 147, 156 & GT 3 24-05-06 06:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome