Wrong Cam Locks? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 14-09-11 Thread Starter
Status: Deserter...
AO Member
 
Join Date: Apr 2011
Location: United Kingdom
County: North Yorkshire
Posts: 513
Wrong Cam Locks?

I bought a pair of new cam locks for a 1996 Spider 2.0 but on trying to fit them to the 3rd keep on each cam they seem to be the wrong profile, the lobe bottoms before the keep nears the head. The numbers are 1825042-1 and 1825042-2, the card in the box says 1825042000, Alfa Romeo 2.0 TS BZ and came in a Alfa box which had already been opened. The number seem to match locks for a 1400/1600 but I'd like to be sure. Can anyone confirm they are the wrong ones please?
spike60 is offline  
Sponsored Links
Advertisement
 
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
wrong positions....

been a while now since I did a ts, but it could be cyl2 on the intake and cyl3 on the exhaust
Cuore_Sportivo_155 is offline  
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
sounds like you the wrong blocks if the numbers match 1.4/1.6 blocks...

https://www.alfaowner.com/Forum/engin...rk-engine.html

check this link for ref:
biffa is offline  
(Post Link) post #4 of 4 Old 15-09-11 Thread Starter
Status: Deserter...
AO Member
 
Join Date: Apr 2011
Location: United Kingdom
County: North Yorkshire
Posts: 513
Thanks for help from all, I bought some more locally which did the job and proved the the 1st ones are not for a2.0 T.S. Now all I have to do is convince original seller his locks aren't as advertised! Paul.
spike60 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
cam , locks , wrong

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong Cam Locks? spike60 Alfa GTV & 916 Spider 7 15-09-11 21:16
GTA cam locks 1G5T6A Alfa GTA 4 31-10-10 18:44
what would happen if a wrong cam belt kit was fitted? bigbambi Alfa 147, 156 & GT 12 07-10-08 01:31
Have I got the right cam locks? paulsco Alfa 147, 156 & GT 52 01-04-07 11:21

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome