156 JTS Alfadiag Engine codes - Motor Control System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 06-09-11 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2009
Location: Australia
County: Queensland
Posts: 2

Member car:

156 JTS

Help 156 JTS Alfadiag Engine codes - Motor Control System Failure

Hi all

I've had my 2001 156 JTS for a couple of fun years now, but I've had a few problems:

Within the first few months it started complaining about one of the lambda sensors, and we had it replaced under warranty.

The problem came up again a few months later, but I haven't tried to fix it again (at that stage, the mechanic suspected we might need to replace the cat, but I didn't want to fork out the money for this, and it's theoretically not a critical issue(?)).

About 3 months ago I got some cylinder 3 misfires. I confirmed it was a coil pack problem by checking the resistance, and swapping the coil pack to a different cylinder. Replacing the coil pack fixed the misfire problem up until recently...

It currently has a rough idle, and yesterday gave me a triple beep warning. I limped home (jerky acceleration and crusing - felt like misfiring), and ran Alfadiag on it.

Among other problems, it's reporting cylinder misfires again, I pulled out the coil packs, but I couldn't find a problem with the resistances.

Having read some of the other reports in this forum, I took it for a quick drive while Alfadiag monitored the battery voltage - it didn't seem to dip at any stage.

Having read about *a lot* of expensive fishing expeditions, I thought I would ask here before taking it to a mechanic. Any ideas?

Alfadiag is reporting the following codes:


p0134:
Failed Component Code: Lambda Sensor Bank 1 (Pre Cat)
Fault Symptom: No Signal
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Not Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 840 rpm
Environmental Condition Two: Relative Load: 27.75 %
Environmental Condition Three: Engine Coolant Temperature: 83.25 C
Environmental Condition Four: Air Temperature: 49.5 C
Environmental Condition Five: Throttle Valve Angle: 1.96
Environmental Condition Six: Battery Voltage: 12.8 volts

p2240:
Failed Component Code: lambda Sensor Bank 2 (Pre Cat)
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 39 count
Environmental Condition One: Engine Speed: 1440 rpm
Environmental Condition Two: Relative Load: 22.5 %
Environmental Condition Three: Engine Coolant Temperature: 90 C
Environmental Condition Four: Air Temperature: 45 C
Environmental Condition Five: Throttle Valve Angle: 1.96
Environmental Condition Six: Battery Voltage: 12.8 volts

p0136:
Failed Component Code: Lambda Sensor Bank 1 (Post Cat)
Fault Symptom: No Signal
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 38 count
Environmental Condition One: Engine Speed: 1800 rpm
Environmental Condition Two: Relative Load: 37.5 %
Environmental Condition Three: Engine Coolant Temperature: 72.75 C
Environmental Condition Four: Air Temperature: 24 C
Environmental Condition Five: Throttle Valve Angle: 7.84
Environmental Condition Six: Battery Voltage: 13.23 volts

p1172:
Failed Component Code: Self Adaptation Multiplacitive parameters FRA Bank 1
Fault Symptom: Above Maximum Limit
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 2120 rpm
Environmental Condition Two: Relative Load: 60 %
Environmental Condition Three: Engine Coolant Temperature: 78 C
Environmental Condition Four: Air Temperature: 26.25 C
Environmental Condition Five: Throttle Valve Angle: 18.04
Environmental Condition Six: Battery Voltage: 13.09 volts

p0300:
Failed Component Code: Random/Multiple Cylinder Misfire Detected
Fault Symptom: Continous (Danger of Overheating Cat)
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 2520 rpm
Environmental Condition Two: Relative Load: 30.75 %
Environmental Condition Three: Engine Coolant Temperature: 72.75 C
Environmental Condition Four: Status of Fuel Level: Not Empty
Environmental Condition Five: Throttle Valve Angle: 9.8
Environmental Condition Six: Battery Voltage: 13.09 volts


p0303:
Failed Component Code: Cylinder 3 Misfire Detected
Fault Symptom: Continous (Danger of Overheating Cat)
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 2520 rpm
Environmental Condition Two: Relative Load: 30.75 %
Environmental Condition Three: Engine Coolant Temperature: 72.75 C
Environmental Condition Four: Status of Fuel Level: Not Empty
Environmental Condition Five: Throttle Valve Angle: 9.8
Environmental Condition Six: Battery Voltage: 13.09 volts


p0302:
Failed Component Code: Cylinder 2 Misfire Detected
Fault Symptom: Continous (Increased Emissions)
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 2640 rpm
Environmental Condition Two: Relative Load: 43.5 %
Environmental Condition Three: Engine Coolant Temperature: 72.75 C
Environmental Condition Four: Status of Fuel Level: Not Empty
Environmental Condition Five: Throttle Valve Angle: 14.12
Environmental Condition Six: Battery Voltage: 13.09 volts

Thanks for any help!
Simon
chupaty is offline  
Sponsored Links
Advertisement
 
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Check the large black connectors at the rear of the engine bay...
biffa is offline  
Status: Falling apart
AO Member
 
m0bzy's Avatar
 
Join Date: Jul 2008
Location: United Kingdom
County: West Midlands
Posts: 410
+1 to above
m0bzy is offline  
(Post Link) post #4 of 4 Old 11-09-11 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2009
Location: Australia
County: Queensland
Posts: 2

Member car:

156 JTS

Hi guys

Thanks for your advice. Before reading your replies, I'd used a bottle of injector cleaner (in-fuel as I couldn't find an air intake bottle at the local auto store). I then cleared the faults.

After reading your post Biffa, I cleaned and reconnected the two connector blocks (electrical cleaner and an old toothbrush - any better suggestions for this?).

Right now it seems to be driving well. I'm hoping that cleaning the connectors has done the trick. From previous experience, I've seen that just clearing the faults seems to make the car go OK for a while (I can't explain why this would be the case).

Will let you know how it goes.

Thanks again
Simon
chupaty is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , alfadiag , codes , control , engine , failure , jts , motor , system

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
JTD/JTDM MCSF & other problems FIX losa Alfa 147, 156 & GT 154 26-09-16 20:05
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome