injector problems- heath robinson test rig. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 14-05-11 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2010
Location: United Kingdom
County: Gloucestershire
Posts: 20
simple diesel injector test rig. Mk1

HI,
Just thought I would put a note on line on how i made a very basic test rig to find out which injector has been playing up and testing the others for leak off.
I used 5 x 50ml syringes purchased from e-bay for a few pounds and a short length of 3mm silicone vacuum tube from Siliconhoses.com in Gloucester.
The cardboard holder will now be replaced by a wooden bracket and the sryinges will be clipped to this. The 3mm tube snugly fits inside the injector leak off apature after the original pipes have been removed.
do not forget to clamp shut the existing leak off pipe before you start the engine.
As you can see on mine the first injector is leaking badly whilst the remaining 4 are all equal in their output.
I will do a more in depth description later but I was so exited about this test I just had to tell someone
attached should be a photo - if I have done the attachment right!
My car by the way is a 2002 2.4 10 valve 156 JTD
now i need a water sensor for the fuel filter and need to find out how to remove the poorly injector.
Ive just re-bult the turbo as it was leaking but firgot to take the photos for that one. Sorry
Attached Images
File Type: jpg DSC_0138.jpg (53.2 KB, 77 views)

Last edited by oldbill; 17-05-11 at 20:20.
oldbill is offline  
Sponsored Links
Advertisement
 
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,124
So the duff injector leak-off force-fills the syringe? Neat one...


Ralf S.
Ralf S. is offline  
(Post Link) post #3 of 6 Old 16-05-11 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2010
Location: United Kingdom
County: Gloucestershire
Posts: 20
Not even force fills, the syringe is minus the plunger and the leak off is low pressure. I have been told that 10% difference is normal but as you can see mine was a bit more than that!!.
I will test again when I put in the next injector - hopefully tomorrow. As long as they are all equal things should be fine. At least I know its only one injector and which one it is.
oldbill is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,124
Ah. okay... I dunno much about the Dark Side..

Still... it looks cheap and simple so it's a Top Tip!


Ralf S.
Ralf S. is offline  
Status: Trying to fix my 159
AO Member
 
Join Date: Feb 2010
Location: Spain
County: Valencia
Posts: 117

Member car:

Alfa 159 2.4

Have you check the injector correction with FES? What values have you got?
adrianuxx is offline  
(Post Link) post #6 of 6 Old 25-05-11 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2010
Location: United Kingdom
County: Gloucestershire
Posts: 20
No, I only have the trial version so i do not think I can do that. Since changing the injector I now get instant starting which has never happenned before and it definately feels smoother.
I did not think you had to make any corrections with the 5 pot engine? if you do please tell.
oldbill is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
heath , injector , problems , rig , robinson , test

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome